[山东科技大学OJ]1107 Problem A: 编写函数:Swap (I) (Append Code)

该博客主要介绍了如何使用C语言和C++编写交换两个整数和双精度浮点数的函数,包括int_swap(), dbl_swap()以及一个SWAP宏。示例代码展示了这些函数在main()函数中的应用,用于读取输入的两组数值并逆序输出。
摘要由CSDN通过智能技术生成

 

Time Limit: 1 Sec Memory Limit: 16 MB

Submit: 17642 Solved: 11482

[Submit][Status]

Description

编写用来交换两个数的函数,使得“Append Code”中的main()函数能正确运行。

 

-----------------------------------------------------------------------------

 

用C实现三个函数int_swap()、dbl_swap()、SWAP(),其中SWAP()是个带参宏。

 

用C++实现两个函数,都以Swap()命名。

 

以上函数的调用格式见“Append Code”。这里不给出函数原型,它们的参数请通过main()函数自行确定。

 

Input

输入为4行,每行2个数。

 

Output

输出为4行,每行2个数。每行输出的两数为每行输入的逆序。

 

Sample Input

12 57

9 -3

-12 4

3 5

Sample Output

57 12

-3 9

4 -12

5 3

HINT

“Append Code”中用到的头文件、全局变量或宏的定义应自行补充。

 

Append Code

append.c, append.cc,

[Submit][Status]


#include <stdio.h>

#include <stdlib.h>

#include <string.h>

#include <ctype.h>

#define SWAP(t,x,y){t=x;x=y;y=t;}

int_swap(int *a,int *b)

{

    int t;

    t=*a;

    *a=*b;

    *b=t;

}

 

dbl_swap(double *a,double *b)

{

    double t;

    t=*a;

    *a=*b;

    *b=t;

}

 

 

int main()

{

    int x1, y1, t1;

    double x2, y2, t2;

 

    scanf("%d %d", &x1, &y1);

    int_swap(&x1, &y1);

    printf("%d %d\n", x1, y1);

 

    scanf("%d %d", &x1, &y1);

    SWAP(t1, x1, y1);

    printf("%d %d\n", x1, y1);

 

    scanf("%lf %lf", &x2, &y2);

    dbl_swap(&x2, &y2);

    printf("%lg %lg\n", x2, y2);

 

    scanf("%lf %lf", &x2, &y2);

    SWAP(t2, x2, y2);

    printf("%lg %lg\n", x2, y2);

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值