L2-011 玩转二叉树
给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N
(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2
#include<bits/stdc++.h>
using namespace std;
using ll = long long;
vector<int>mi,fr,l_s,r_s;
void build_t(int l1,int r1,int l2,int r2){
//cout<<l1<<" "<<r1<<" "<<l2<<" "<<r2<<endl;
auto pos=find(mi.begin()+l2,mi.begin()+r2+1,fr[l1])-mi.begin();
int num = pos-l2-1;
if(pos>=l2+1){
l_s[l1]=l1+1;
if(pos>l2+1) build_t(l1+1,l1+num+1,l2,pos-1);
}
if(pos<=r2-1){
r_s[l1]=num+l1+2;
if(pos<r2-1) build_t(l1+num+2,r1,pos+1,r2);
}
}
void bfs(int r){
queue<int>q;
q.push(r);
while(!q.empty()){
int t = q.front();
q.pop();
if(r_s[t]!=0) q.emplace(r_s[t]);
if(l_s[t]!=0) q.emplace(l_s[t]);
cout<<fr[t];
if(q.size()!=0) cout<<" ";
}
}
int main(){
cout.sync_with_stdio(false);
cout.tie(nullptr);
int n;cin>>n;
mi.assign(n+1,0);
fr.assign(n+1,0);
l_s.assign(n+1,0);
r_s.assign(n+1,0);
for(int i=1;i<=n;i++) cin>>mi[i];
for(int i=1;i<=n;i++) cin>>fr[i];
build_t(1,n,1,n);
bfs(1);
}