L2-012 关于堆的判断
将一系列给定数字顺序插入一个初始为空的最小堆。随后判断一系列相关命题是否为真。命题分下列几种:
x is the root
:x
是根结点;x and y are siblings
:x
和y
是兄弟结点;x is the parent of y
:x
是y
的父结点;x is a child of y
:x
是y
的一个子结点。
输入格式:
每组测试第 1 行包含 2 个正整数 n(≤ 1000)和 m(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间 [−10000,10000] 内的 n 个要被插入一个初始为空的最小堆的整数。之后 m 行,每行给出一个命题。题目保证命题中的结点键值都是存在的。
输出格式:
对输入的每个命题,如果其为真,则在一行中输出 T
,否则输出 F
。
输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T
题目引用自团体程序设计天梯赛真题(2016年)。
#include<bits/stdc++.h>
using namespace std;
int main(){
int n,m;cin>>n>>m;
vector<int>v(n+1);
for(int i=1;i<=n;i++){
cin>>v[i];
int j=i;
while(j>1&&v[j]<v[j/2]) swap(v[j],v[j/2]),j/=2;
}
map<int,int>mp;
for(int i=1;i<=n;i++){
mp[v[i]]=i;
}
getchar();
while(m--){
string s;
int a,b;cin>>a;
cin>>s;
if(s=="and"){
cin>>b;
getline(cin,s);
if(mp[a]/2==mp[b]/2&&mp[a]!=0&&mp[b]!=0) cout<<"T\n";
else cout<<"F\n";
}else{
cin>>s;cin>>s;
if(s=="root"){
if(mp[a]==1) cout<<"T\n";
else cout<<"F\n";
}else if(s=="parent"){
cin>>s;cin>>b;
if(v[mp[b]/2]==a&&mp[a]!=0&&mp[b]!=0) cout<<"T\n";
else cout<<"F\n";
}else{
cin>>s;cin>>b;
if(v[mp[a]/2]==b&&mp[a]!=0&&mp[b]!=0) cout<<"T\n";
else cout<<"F\n";
}
}
}
}