Prime ring problem(素数环问题)

题目描述:
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.


输入:
n (1 < n < 17).

输出:
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

样例输入:
6
8
样例输出:
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=22;
int n,vis[N],a[N];
int flag[55],isp[55];///isp[i]是记录i是否为素数的数组
void is_prime()///素数打表
{
    int k=0;
    memset(isp,0,sizeof(isp));
    memset(flag,0,sizeof(0));
    for(int i=2; i<=7; i++)
        if(!flag[i])
            for(int j=i*i; j<=50; j+=i)
                flag[j]=1;//筛选素数的方法
    for(int i=2; i<=50; i++)
        if(!flag[i])
            isp[i]=1;
}
void init()///初始化
{
    for(int i=0; i<N; i++)
        a[i]=i+1;
}
void dfs(int x)
{
    if(x==n&&isp[a[0]+a[n-1]])///每个数都用到且首位元素和为素数
    {
        printf("%d",a[0]);
        for(int i=1; i<n; i++)
            printf(" %d",a[i]);
        printf("\n");
    }
    else
        for(int i=2; i<=n; i++) ///尝试放每个数
        {
            if(!vis[i]&&isp[i+a[x-1]])///若i没用过且与前一个数的和为素数
            {
                a[x]=i;///储存这个数
                vis[i]=1;
                dfs(x+1);
                vis[i]=0;
            }
        }
}
int main()
{
    is_prime();
    int k=0;
    while(~scanf("%d",&n))
    {
        init();
        printf("Case %d:\n",++k);
        memset(vis,0,sizeof(vis));
        dfs(1);
        printf("\n");
    }
    return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值