综合实验配置

本文详细描述了在一个企业网络环境中,如何配置IP地址、实现不同设备之间的公网互通,包括PPP和CHAP认证,以及使用MGRE、NHRP和RIP协议确保路由可达性。同时涉及了NAT设置以允许私有IP访问公网资源。
摘要由CSDN通过智能技术生成

1,配置IP地址

R1:

[R1]dis ip interface brief 

Interface                         IP Address/Mask      Physical   Protocol  
GigabitEthernet0/0/0              192.168.1.254/24     up         up             
Serial4/0/0                       15.1.1.1/24          up         up              
Tunnel0/0/0                       10.1.2.1/24          up         up        
Tunnel0/0/1                       10.1.1.1/24          up         up 

R2:

[R2]dis ip interface brief 

Interface                         IP Address/Mask      Physical   Protocol  
GigabitEthernet0/0/0              192.168.2.254/24     up         up             
NULL0                             unassigned           up         up(s)           
Serial4/0/0                       25.1.1.2/24          up         up             
Tunnel0/0/0                       10.1.2.2/24          up         up 

R3:

[R3]dis ip interface brief 

Interface                         IP Address/Mask      Physical   Protocol  
GigabitEthernet0/0/0              192.168.3.254/24     up         up             
NULL0                             unassigned           up         up(s)         
Serial4/0/0                       35.1.1.3/24          up         down          
Tunnel0/0/0                       10.1.2.3/24          up         down   

R4:

[R4]dis ip interface brief 

Interface                         IP Address/Mask      Physical   Protocol  
GigabitEthernet0/0/0              45.1.1.4/24          up         up        
GigabitEthernet0/0/1              192.168.4.254/24     up         up             
NULL0                             unassigned           up         up(s)     
Tunnel0/0/1                       10.1.1.4/24          up         up  

R5:

[R5]dis ip interface brief 

Interface                         IP Address/Mask      Physical   Protocol  
GigabitEthernet0/0/0              45.1.1.5/24          up         up                
LoopBack1                         5.5.5.5/24           up         up(s)     
NULL0                             unassigned           up         up(s)          
Serial3/0/1                       25.1.1.5/24          up         up        
Serial4/0/0                       35.1.1.5/24          up         down      
Serial4/0/1                       15.1.1.5/24          up         up  

PC1:192.168.1.1/24

PC2:192.168.4.2/24

PC3:192.168.2.3/24

PC4:192.168.3.4/24

2,实现公网互通

[R1]ip route-static 0.0.0.0 0 15.1.1.5
[R2]ip route-static 0.0.0.0 0 25.1.1.5
[R3]ip route-static 0.0.0.0 0 35.1.1.5
[R4]ip route-static 0.0.0.0 0 45.1.1.5

3,配置认证

(1)R1和R5间使用PPP的PAP认证,R5为主认证方:

R5

[R5]aaa
[R5-aaa]local-user zhangdaye password cipher zdy123
Info: Add a new user.
[R5-aaa]local-user zhangdaye service-type ppp
[R5-aaa]q
[R5]int s4/0/1
[R5-Serial4/0/1]ppp authentication-mode pap

R1

[R1]int s 4/0/0
[R1-Serial4/0/0]ppp pap local-user zhangdaye password cipher zdy123

(2)R2与R5之间使用ppp的CHAP认证,R5为主认证方;

R5

[R5]int s 3/0/1	
[R5-Serial3/0/1]ppp authentication-mode chap 

R2

[R2]int s 4/0/0
[R2-Serial4/0/0]ppp chap user zhangdaye
[R2-Serial4/0/0]ppp chap password cipher zdy123

(3)R3与R5之间使用HDLC封装;

R3:

[R3-Serial4/0/0]link-protocol hdlc

R5:

[R5-Serial4/0/0]link-protocol hdlc 

4,R1、R2、R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE;

(1)配置tunnel隧道:

R1:
0/0/0:
[R1]int t 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.2.1 24	
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R1-Tunnel0/0/0]source 15.1.1.1
0/0/1
[R1]int t 0/0/1	
[R1-Tunnel0/0/1]ip address 10.1.1.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre 
[R1-Tunnel0/0/1]source 15.1.1.1
[R1-Tunnel0/0/1]destination 45.1.1.4

R2:
[R2]int t 0/0/0
[R2-Tunnel0/0/0]ip address 10.1.2.2 24
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R2-Tunnel0/0/0]source 25.1.1.2

R3:
[R3]int t 0/0/0
[R3-Tunnel0/0/0]ip address 10.1.2.3 24	
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R3-Tunnel0/0/0]source 35.1.1.3

R4:
[R4]int t 0/0/1
[R4-Tunnel0/0/1]ip address 10.1.1.4 24	
[R4-Tunnel0/0/1]tunnel-protocol gre 
[R4-Tunnel0/0/1]source 45.1.1.4
[R4-Tunnel0/0/1]destination 15.1.1.1

(2)NHRP的配置,中心站点配置:

[R1]int t 0/0/0
[R1-Tunnel0/0/0]nhrp network-id 100

[R2]int t 0/0/0
[R2-Tunnel0/0/0]nhrp network-id 100
[R2-Tunnel0/0/0]nhrp entry 10.1.2.1 15.1.1.1 register 

[R3]int t 0/0/0
[R3-Tunnel0/0/0]nhrp network-id 100
[R3-Tunnel0/0/0]nhrp entry 10.1.2.1 15.1.1.1 register 

5,整个私有网络基本RIP全网可达,

(1)配置RIP路由协议来传递两端私网路由

[R1]rip 1
[R1-rip-1]undo summary 
[R1-rip-1]v 2	
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 10.0.0.0

[R2]rip 1
[R2-rip-1]undo summary 
[R2-rip-1]v 2
[R2-rip-1]network 192.168.2.0
[R2-rip-1]network 10.0.0.0

[R3]rip 1
[R3-rip-1]undo summary 
[R3-rip-1]v 2	
[R3-rip-1]network 192.168.3.0
[R3-rip-1]network 10.0.0.0

[R4]rip 1	
[R4-rip-1]undo summary 
[R4-rip-1]v 2
[R4-rip-1]network 192.168.4.0	
[R4-rip-1]network 10.0.0.0

(2)在中心上开启伪广播,关闭RIP的水平分割机制

[R1]int t 0/0/0
[R1-Tunnel0/0/0]nhrp entry multicast dynamic 	
[R1-Tunnel0/0/0]undo rip split-horizon 

[R2-Tunnel0/0/0]undo rip split-horizon 

[R3-Tunnel0/0/0]undo rip split-horizon 

[R4-Tunnel0/0/0]undo rip split-horizon 

6,所有pc设置私有IP为源IP,可以访问R5环回,达到全网通。

[R1]acl 2000
[R1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[R1]int s 4/0/0
[R1-Serial4/0/0]nat outbound 2000

[R2]acl 2000
[R2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[R2-acl-basic-2000]q
[R2]int s 4/0/0
[R2-Serial4/0/0]nat outbound 2000

[R3]acl 2000
[R3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[R3-acl-basic-2000]q
[R3]int s 4/0/0
[R3-Serial4/0/0]nat outbound 2000

[R4]acl 2000
[R4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255
[R4-acl-basic-2000]q
[R4]int g 0/0/0
[R4-GigabitEthernet0/0/0]nat outbound 2000

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值