PAT真题-PAT Ranking

    最近在做pat的真题,所以想和大家分享一下感觉比较有意思的题目。

   下面这道题没什么特别难的,主要是回忆c++的相关语法和思想。话不多说,下面就来看看题目吧。

    1025 PAT Ranking (25 分)

   Programming Ability Test is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

     Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

    1.registration_number 

    2.final_rank 

    3.location_number 

    4.local_rank

   The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

    Sample Input:

    2
    5
    1234567890001 95
    1234567890005 100
    1234567890003 95
    1234567890002 77
    1234567890004 85
    4
    1234567890013 65
    1234567890011 25
    1234567890014 100
    1234567890012 85

    Sample Output:

    9
    1234567890005 1 1 1
    1234567890014 1 2 1
    1234567890001 3 1 2
    1234567890003 3 1 2
    1234567890004 5 1 4
    1234567890012 5 2 2
    1234567890002 7 1 5
    1234567890013 8 2 3

    1234567890011 9 2 4

 

    其实这道题的核心思想就是会使用algorithm下的sort函数和会使用struct构造结构体,还需要注意的是registration_number虽然是13位的数字,但有可能会被定义为0001234567890这种形式,所以要定义为string型。下面大家可以看看我的代码:

#include <iostream>

#include <string>

#include <algorithm>

using namespace std;

 

struct student{

  string id;

  int score;

  int final_rank;

  int local_rank;

  int location_number;

}students[30010];

 

bool cmp(student a, student b){

  if(a.score!=b.score){

    return a.score > b.score;

  }else{

    return (a.id).compare(b.id)<0;

  }

}

 

int main(){

  int n,k,i=0,j=0,sum=0,score,rank;

  string id;

  cin >> n;

  for(i=0;i<n;i++){

    cin >> k;

    for(j=0;j<k;j++){

      cin >> id >> score;

      students[sum].location_number = (i+1);

      students[sum].id = id;

      students[sum++].score = score;

    }

    sort(students+sum-k,students+sum,cmp);

    for(j=1;j<=k;j++){

      if(j==1){

        students[sum-k].local_rank = 1;

        rank = 1;

      }

      if(j!=1&&(students[sum-k+j-1].score == students[sum-k+j-2].score)){

        students[sum-k+j-1].local_rank = rank;

      }else{

        rank = j;

        students[sum-k+j-1].local_rank = rank;

      }

    }

  }

  sort(students,students+sum,cmp);

  for(j=1;j<=sum;j++){

    if(j==1){

      students[0].final_rank = 1;

      rank = 1;

    }

    if(j!=1&&(students[j-2].score == students[j-1].score)){

      students[j-1].final_rank = rank;

    }else{

      rank = j;

      students[j-1].final_rank = rank;

    }

  }

  cout << sum << endl;

  for(i=0;i<sum;i++){

    cout << students[i].id << " " <<students[i].final_rank << " " << students[i].location_number << " " << students[i].local_rank << endl;

  }

  return 0;

}

 

    以上代码可能会存在错误,如有错误还请在后台和我讨论,一起进步,当然对于代码有什么疑问的也可以在后台和我交流啊。(作者的公众号是:faceSchool)

 

微信扫一扫
关注该公众号

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值