HDU - 1024----Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 … S x, … S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + … + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + … + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 … S n.
Process to the end of file.
Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8

题目大意:给定n个数,和m个段。求在这n个数中求出m个子段,使得这些子段的和最大。就是区间求和的升级版

我的另一篇博文 最大区间和

思路:
//仿照区间求和得出状态转移方程
//j个数(j<=n) i段序列(i<=m)
//在i段序列中:对于第j个数来说他要么处在i段序列中最后一段的最后一个数
//要么是i段序列中最后的一段(第i段),即可得出 状态转移方程
//dp[i][j]=max(dp[i][j-1]+A[j],dp[i-1][k]+A[j]) (i-1<=k<=j-1)
//dp[i][j]就是j个数分成i段序列
//n太大所以用滚动数组实现上述状态转移方程。

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<queue>
using namespace std;

const int MAX=1000009;
const int INF = 0x7fffffff;

int n,m; 
int A[MAX],dp[MAX],tem[MAX];

int DP(int m,int n){
    int ret;

    for(int i=1 ; i<=m ; i++){//分成m段 
        ret = -INF;
        for(int j=i ; j<=n ; j++){//n个数
            //状态转移方程 
            dp[j] = max(dp[j-1]+A[j],tem[j-1]+A[j]);

            //更新tem,使其为前j-1个数中的序列和最优解,并存下他
            tem[j-1] = ret;    

            //更新ret其为前j个数中的序列和最优解
             ret = max(ret,dp[j]);
        }    
    }
    return ret;
}

int main(void){
    while(scanf("%d%d",&m,&n)!=EOF){
        dp[0] = tem[0]=0;   
        for(int i=1 ; i<=n ; i++){
            cin>>A[i];
            tem[i]=0;
            dp[i]=0;
        }
        cout<<DP(m,n)<<endl;
    } 
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值