POJ - 1287----Networking(prim)

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input
The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.
Output
For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0
Sample Output
0
17
16
26

题目大意:给你n个点,m条边,让你求组成通路的最小生成树。
思路:prim模板

#include<cstdio> 
#include<iostream>
#include<algorithm> 
using namespace std;
const int MAX = 100;
const int INF = 0x3f3f3f3f;

//最小生成树prim算法 
struct A{
    int arcs[MAX][MAX]; //权值-->边的长度 
    int arcnum;         //边的数目 
    bool visit[MAX];    //顶点的访问情况 
    int vexnum;         //顶点的数目 
}G;
int d[MAX];//选中集与未选中集的距离 

int prim(void){  
    int min,v,ans=0;  
    for(int i=1 ; i<=G.vexnum ; i++){  
        d[i] = G.arcs[1][i]; 
        G.visit[i] = false;//每个点未访问 
    }
    //起始点加入选中集 
    G.visit[1]=true;

    for(int i=1 ; i<G.vexnum ; i++){//选n-1个定点 
        //找出一个最短距离的点 
        min=INF;
        for(int j=1 ; j<=G.vexnum ; j++){  
            if(!G.visit[j] && d[j]<min){  
                v=j;  
                min = d[j];  
            }  
        }  
        //已访问 
        G.visit[v]=true;
        ans += min;
        //更新选中点集与未选中点集的距离
        for(int j=1 ; j<=G.vexnum ; j++){
            if(!G.visit[j] && G.arcs[v][j]<d[j]){      
                d[j]= G.arcs[v][j];  
            }
        } 
    }  

    return ans;  
}  

int main(void){  
    int a,b,weight;  
    while(cin>>G.vexnum && G.vexnum && cin>>G.arcnum){  
        //初始化图 
        for(int i=1 ; i<=G.vexnum ; i++){
            for(int j=1 ; j<=G.vexnum ; j++){
                G.arcs[i][j] = (i==j)?0:INF;  
            }
        }
        //赋权值 
        for(int i=1 ; i<=G.arcnum ; i++){  
            cin>>a>>b>>weight;
            G.arcs[a][b] = min(G.arcs[a][b],weight); 
            G.arcs[b][a] = G.arcs[a][b];  
        } 
        cout<<prim()<<endl;  
    }  
    return 0;  
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值