POJ 1847----Tram(Floyd)

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.
Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.
Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2
Sample Output

0

题目大意:给出n个站点,每个站点都有铁路通向其他站点 如果当前要走得路恰好是该站点的开关指向的铁路,则不用扳开关,否则要手动扳动开关,给出起点和终点,问最少需要扳动多少次开关.
思路:算是个Floyd模板吧

#include<algorithm>
#include<iostream>
#include<stdlib.h>
#include<cstring>
#include<cstdio>
#include<cstdio>
#include<cmath>
#include<queue>
using namespace std;
const int MAX = 105;
const int INF = 0x3f3f3f3f;

struct A{
    int vexnum;
    int arcnum;
    int arcs[MAX][MAX];
}G;

int dis[MAX][MAX];   //所有点之间的最短距离 

//多源最短路Floyd算法
void Floyd(int start,int end){
    for(int i=1 ; i<=G.vexnum ; i++){
        for(int j=1 ; j<=G.vexnum ; j++){
            dis[i][j] = G.arcs[i][j];
        }
    }

    for(int k=1 ; k<=G.vexnum ; k++){
        for(int i=1 ; i<=G.vexnum ; i++){
            for(int j=1 ; j<=G.vexnum ; j++){
                dis[i][j] = min(dis[i][j],dis[i][k]+dis[k][j]);
            }
        }   
    }

    if(dis[start][end] == INF){
        cout<<-1<<endl;
    }else{
        cout<<dis[start][end]<<endl;
    }
    return ;
}
int main(void){
    int start,end,ans;
    cin>>G.vexnum>>start>>end;
    for(int i=1 ; i<=G.vexnum ; i++){
        for(int j=1 ; j<=G.vexnum ; j++){
            G.arcs[i][j] = (i==j)?0:INF;  
        }
    }
    for(int i=1 ; i<=G.vexnum ; i++){
        int k,y;
        cin>>k;
        for(int j=1 ; j<=k ; j++){   
            cin>>y;
            G.arcs[i][y] = (j==1)?0:min(1,G.arcs[i][y]);
        }
    }

    Floyd(start,end);

    return 0;
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值