poj-1847 Tram 最短路

http://poj.org/problem?id=1847

Tram
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13437 Accepted: 4944

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B. 

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed. 

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0
题意:一辆车要从A地到B地,要经过岔路口,每个路口都有一个指示牌,此时可以按指示牌走,还可以移动一次指示盘,超移动后的方向走,要求A到B走的岔路口的最小数量,注意构图,求A到B的最短路即可

注意输入,输入n、a、b,接下来的n行,表示第i行有k个岔路,其中原始指示盘指向第一个的方向


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define INF 99999999
using namespace std;
int g[110][110];
int main(){
    int n, a, b, i, j, k, m;
    while(~scanf("%d%d%d",&n,&a,&b)){
        for(i=0; i<=n; i++){
            for(j=0; j<=n; j++){
                if(i==j)
                    g[i][j] = 0;
                else
                    g[i][j] = INF;
            }
        }
        for(i=1; i<=n; i++){
            scanf("%d",&k);
            for(j=0; j<k; j++){
                scanf("%d",&m);
                if(j==0)
                    g[i][m] = 0;
                else g[i][m] = 1;
            }
        }
        for(k=1; k<=n; k++){
            for(i=1; i<=n; i++){
                for(j=1; j<=n; j++){
                    if(g[i][j]>g[i][k]+g[k][j])
                        g[i][j] = g[i][k]+g[k][j];
                }
            }
        }
        if(g[a][b]==INF)
            cout<<"-1"<<endl;
        else
            cout<<g[a][b]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值