A+B for Input-Output Practice (VIII)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 115017 Accepted Submission(s): 35331
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
Sample Output
10 15 6
水题,注意输出就好。
#include<stdio.h>
int main()
{
int n,m,x,sum,i,p;
//freopen("input.txt","r",stdin);
scanf("%d",&n);p=n;
while(n--)
{
sum=0;
if(p!=n+1)printf("\n");
scanf("%d",&m);
for(i=0;i<m;i++)
{
scanf("%d",&x);
sum+=x;
}
printf("%d\n",sum);
}
//fclose(stdin);
return 0;
}