UVa 1586 Molar Mass


UVa 1586 Molar Mass

An organic compoundis any member of a large class of chemical compounds whose molecules containcarbon. The molar mass of an organic compound is the mass of one mole of theorganic compound. The molar mass of an organic compound can be computed fromthe standard atomic weights of the elements.

When an organic compound is given as amolecular formula, Dr. CHON wants to find its molar mass. A molecular formula,such as C3H4O3 , identifies each constituent element by its chemical symbol andindicates the number of atoms of each element found in each discrete moleculeof that compound. If a molecule contains more than one atom of a particularelement, this quantity is indicated using a subscript after the chemicalsymbol.

In this problem, we assume that the molecularformula is represented by only four elements, `C' (Carbon), `H' (Hydrogen), `O' (Oxygen), and `N' (Nitrogen)without parentheses.

The following table shows that thestandard atomic weights for `C', `H', `O', and `N'.

For example, the molar mass of a molecularformula C6H5OH is 94.108g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00g/mol).

Given a molecular formula, write a programto compute the molar mass of the formula.



Input

Your program is to read from standardinput. The input consists of T testcases. The number of test cases T isgiven in the first line of the input. Each test case is given in a single line,which contains a molecular formula as a string. The chemical symbol is given bya capital letter and the length of the string is greater than 0 and 3900 - Molar mass1/2 less than 80. The quantity numbern which is represented after the chemical symbol would be omitted when thenumber is 1 (2 <= n <=99) .

Output

Your program is to write to standardoutput. Print exactly one line for each test case. The line should contain themolar mass of the given molecular formula.

Sample Input

4

C

C6H5OH

NH2CH2COOH

C12H22O11

Sample Output

12.010

94.108

75.070

342.296



<span style="font-size:14px;">#include<stdio.h>
int main()
{
	int m,i,j,C,H,O,N,temp;
	double x;
	char s[100];
	scanf("%d",&m);
	while(m--)
	{
		C=H=O=N=0;
		scanf("%s",s);
		for(i=0;s[i];i++)
		{
			if(s[i]=='C')
			{
				temp=0,j=i+1;
				while(s[j]<='9'&&s[j]>'0')	
				{	
					temp=temp*10+s[j]-'0';
					j++;
				}
				if(j==(i+1)) {i=j-1;C++;}
				C+=temp;
			}
			else if(s[i]=='H')
			{
				temp=0,j=i+1;
				while(s[j]<='9'&&s[j]>'0')	
				{	
					temp=temp*10+s[j]-'0';
					j++;
				}
				if(j==(i+1)) {i=j-1;H++;}
				H+=temp;
			}
			else if(s[i]=='O')
			{
				temp=0,j=i+1;
				while(s[j]<='9'&&s[j]>'0')	
				{	
					temp=temp*10+s[j]-'0';
					j++;
				}
				if(j==(i+1)) {i=j-1;O++;}
				O+=temp;
			}
			else if(s[i]=='N')
			{
				temp=0,j=i+1;
				while(s[j]<='9'&&s[j]>'0')	
				{	
					temp=temp*10+s[j]-'0';
					j++;
				}
				if(j==(i+1)) {i=j-1;N++;}
				N+=temp;
			}
			
		}
		x=12.01*C+1.008*H+16.00*O+14.01*N;
		printf("%.3f\n",x);

	}
	return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值