1207#POJ1042 Gone Fishing


摘要
-给定一连串湖的鱼量和鱼的每被抓一次的减少量和总的时间以及湖与湖之间消耗的时间,分配出最佳的方案来使鱼钓得最多;
原题目摘要
-  Gone Fishing http://poj.org/problem?id=1042

descriptoin
John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. 
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.
Input
You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in  which n = 0.
Output
For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. 
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.
Sample Input
2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 
Sample Output
45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

题目理解
-基本上算是遍历搜索到头了,先对第一个湖花的时间从小到达一次增加,来选出最大的鱼数量;结合记忆化搜索fishing(k,t):从第k个鱼塘起用t 的时间 钓到最多的鱼;要记录每个湖的花费时间使用啊KT[][]数组记录,就用一个指针指向下一次钓鱼的最佳方案;
注意
-个人感觉 有些时间消耗是不必要的,由于题目要求要尽量把时间放在前面的湖,想着到某个时间就直接把时间加满,结果不行;

题目时间间隔是 5min  我直接用其作为单位时间;输出的时候乘以5就行了

题目过用了1+S 不知道为啥没有tle
日期
-2017 12 7
附加
-
代码
-



#include <algorithm>
#include <cstdio>
#include <iostream>
#define MAX 30
using namespace std;

struct Node{
    bool vis;
    int cost,cur_max;
    Node *next;
    void init(){
        vis = false;
        cost=cur_max = -1;
        next = NULL;
    }
};

int n;
int Di[MAX];
int Ti[MAX];
int Fi[MAX],fi[MAX];
Node KT[30][20*12];


Node *fishing(int k,int t){
    if(t<=0||k==n) return NULL;
    if(KT[k][t].vis) return &KT[k][t];
    Node &node = KT[k][t];

    node={true,0,0,NULL};
    node.next = fishing(k+1,t-Ti[k]);
    node.cur_max = node.next?node.next->cur_max:0;
    Fi[k]=fi[k];
    int cur = 0,next_cur=0;
    int next_t ;
    for(int i=1;i<=t;i++){
        next_t = t-i-Ti[k];
        if(fishing(k+1,next_t)){
                next_cur=fishing(k+1,next_t)->cur_max;
        }else next_cur = 0;
        if(Fi[k]>0){
            cur+=Fi[k];
            Fi[k]-=Di[k];
        }
        if(cur+next_cur>=node.cur_max){
            node.next = fishing(k+1,next_t);
            node.cur_max = cur+next_cur;
            node.cost = i;
        }
    }

    return &KT[k][t];
}

void solve(int t){
    for(int i=0;i<n;i++){scanf("%d",&Fi[i]);fi[i]=Fi[i];}
    for(int i=0;i<n;i++)scanf("%d",&Di[i]);
    for(int i=0;i<n-1;i++)scanf("%d",&Ti[i]);
    for(int i=0;i<n;i++){
        for(int j=0;j<=t;j++){
            KT[i][j].init();
        }
    }
    Node *ans = fishing(0,t);
    int ans_cnt = ans?ans->cur_max:0;

    for(int i=0;i<n;i++){
        if(i)printf(", ");
        printf("%d",5*(ans?(ans->cost):0));
        ans=ans?ans->next:NULL;
    }
    printf("\nNumber of fish expected: %d\n\n",ans_cnt);
}
int main(){
    int h;
    while(scanf("%d",&n)&&n){
        scanf("%d",&h);
        solve(12*h);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值