1009 FatMouse' Trade

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500

题目说的是非负数,那么输入的就有可能是0

第15行就是要解决N为0的情况。

第8行的后面是> >,中间有空格,不然OJ编译有错误!

#include <iostream>
#include <map>
#include <iomanip>
using namespace std;
int main()
{
	pair<int,int> pd;
	pair<double,pair<int,int> > pp;
	multimap<double,pair<int,int> > mymap;
	multimap<double,pair<int,int> >::reverse_iterator pos;
	int M,N,j;
	double sum;
	while (cin>>M>>N&&(M!=-1&&N!=-1))
	{
		if (N==0)
		{
			cout<<"0.000"<<endl;
			continue;
		}
		j=0;
		while (j<N)
		{
			cin>>pd.first>>pd.second;
			pp.first=(double)((double)pd.first/(double)pd.second);
			pp.second=pd;
			mymap.insert(pp);
			++j;
		}
		pos=mymap.rbegin();
		sum=0.0000;
		while (M>0)
		{
			if (M>=pos->second.second)
			{
				sum+=(pos->second.first);
				M-=(pos->second.second);
				++pos;
			}
			else
			{
				sum+=((double)M)*pos->first;
				break;
			}
		}
		cout<<fixed<<setprecision(3)<<sum<<endl;
		mymap.clear();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值