poj1002 487-3279

这是题目:

6:487-3279
查看 提交 统计 提问
总时间限制: 2000ms 内存限制: 65536kB
描述
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

输入
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.
输出
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.
样例输入
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279
样例输出
310-1010 2
487-3279 4
888-4567 3

来源
East Central North America 1999


========================================================================

偷了个懒,利用了STL map容器中元素的key在插入时保持有序的特性。我把之前一篇博文中的相关内容截了个图:


此题中(p->first)是标准化后的电话号码,(p->second)是这个电话号码出现的次数。

========================================================================


代码清单:

#include <iostream>
#include <cstdio>
#include <string>
#include <map>	//偷个懒,利用map中元素有序的性质
using namespace std;

#define MAXLEN 205
#define NORMLEN 10

map<char, char> c2dtable;	//char to digit(still presented in char though) table
map<string, int> outlist;	//string记录电话号码,int记录出现的次数

char current[MAXLEN];
char normed[NORMLEN];

void FillTable()
{
	c2dtable['A']='2';	c2dtable['B']='2'; c2dtable['C']='2';
	c2dtable['D']='3';	c2dtable['E']='3'; c2dtable['F']='3';
	c2dtable['G']='4';	c2dtable['H']='4'; c2dtable['I']='4';
	c2dtable['J']='5';	c2dtable['K']='5'; c2dtable['L']='5';
	c2dtable['M']='6';	c2dtable['N']='6'; c2dtable['O']='6';
	c2dtable['P']='7';	c2dtable['R']='7'; c2dtable['S']='7';
	c2dtable['T']='8';	c2dtable['U']='8'; c2dtable['V']='8';
	c2dtable['W']='9';	c2dtable['X']='9'; c2dtable['Y']='9';
}

void ScanList(int n)
{
	char *p;
	int index;
	string tempStr;

	for (int i=0; i<n; ++i)
	{
		scanf("%s", current);

		//将电话号码的格式规范化
		for (index=0, p=current; *p!='\0';)
		{
			if (index==3)
			{
				normed[index]='-';
				++index;
			}
			else
			{
				if(*p=='-') ++p;
				else if( (*p>='0') && (*p<='9') )
				{
					normed[index]=*p;
					++index;
					++p;
				}
				else
				{
					normed[index]=c2dtable[*p];
					++index;
					++p;
				}
			}
		}
		normed[index]='\0';	//字符串结束标记

		//规范化之后可以插入map。由map的性质,插入之后元素的key保持有序。
		tempStr=normed;
		if (outlist.count(tempStr) == 0)	//没有这个电话号码
		{
			outlist[tempStr]=1;	//这个电话号码是第一个记录,出现次数是1
		}
		else
		{
			++outlist[tempStr];
		}
	}
}

void PrintList()
{
	bool NoDuplicates=true;
	for (map<string, int>::iterator i=outlist.begin(); i!=outlist.end(); ++i)
	{
		if (i->second > 1)	//有重复的电话号码
		{
			printf("%s %d\n", i->first.c_str(), i->second);
			NoDuplicates=false;
		}
	}

	if (NoDuplicates)
	{
		printf("No duplicates.\n");
	}
}

int main()
{
	freopen("D:\\in.txt", "r", stdin);  
	freopen("D:\\out.txt", "w", stdout);  

	int n;
	scanf("%d", &n);

	FillTable();
	ScanList(n);
	PrintList();

	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值