Hdu 5090 Game with Pearls(二分匹配)

点击打开链接

Game with Pearls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 70    Accepted Submission(s): 51


Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K.

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins.

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
 

Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
 

Output
For each game, output a line containing either “Tom” or “Jerry”.
 

Sample Input
  
  
2 5 1 1 2 3 4 5 6 2 1 2 3 4 5 5
 

Sample Output
  
  
Jerry Tom

题意:n个数,现在可以分别将每个数,加上k的整数倍或0。问最后是否能将n个数,改变成1到n的排列。

题解:如果一个数x能加上k的整数倍或0变成y,则在x和y之间建一条边。建完图跑最大匹配,如果最大匹配为n则有解。

代码如下:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stack>
#include<vector>
#include<queue>
#include<string.h>
#define inff 0x3fffffff
#define nn 110
using namespace std;
int n,k;
int a[nn];
struct node
{
    int st,en,next;
}E[nn*nn];
int p[nn],num;
void init()
{
    memset(p,-1,sizeof(p));
    num=0;
}
void add(int st,int en)
{
    E[num].en=en;
    E[num].next=p[st];
    p[st]=num++;
}
int pre[nn];
bool vis[nn];
bool dfs(int id)
{
    int i,w;
    for(i=p[id];i+1;i=E[i].next)
    {
        w=E[i].en;
        if(!vis[w])
        {
            vis[w]=true;
            if(pre[w]==-1||dfs(pre[w]))
            {
                pre[w]=id;
                return true;
            }
        }
    }
    return false;
}
void solve()
{
    int i;
    int re=0;
    memset(pre,-1,sizeof(pre));
    for(i=1;i<=n;i++)
    {
        memset(vis,false,sizeof(vis));
        if(dfs(i))
            re++;
    }
    if(re==n)
        puts("Jerry");
    else
        puts("Tom");
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        init();
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if((j-a[i])>=0&&(j-a[i])%k==0)
                {
                    add(i,j);
                }
            }
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值