hdu 5090 二分匹配 or 排序

Game with Pearls

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 143 Accepted Submission(s): 95


Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K.

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins.

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.

Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.

Output
For each game, output a line containing either “Tom” or “Jerry”.

Sample Input
  
  
2 5 1 1 2 3 4 5 6 2 1 2 3 4 5 5

Sample Output
  
  
Jerry Tom

Source

二分匹配:当前数和当前数可以变成的数建边,求最大匹配
#include<stdio.h>
#include<string.h>
#define N 200
int map[N][N],mark[N],pre[N],n,a[N];
int find(int k)
{
    int i;
    for(i=1;i<=n;i++)
    {
        if(map[k][i]==1&&!mark[i])
        {
            mark[i]=1;
            if(pre[i]==-1||find(pre[i]))
            {
                pre[i]=k;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t,b,i,k,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        memset(map,0,sizeof(map));
        memset(pre,-1,sizeof(pre));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b=a[i];
            while(b<=n)
            {
                map[a[i]][b]=1;
                b+=k;
            }
        }
        sum=0;
        for(i=1;i<=n;i++)
        {
            memset(mark,0,sizeof(mark));
            sum+=find(a[i]);
        }
        if(sum==n)
            printf("Jerry\n");
        else
            printf("Tom\n");
    }
    return 0;
}

先排序,然后让当前没有匹配的最小的数加上k,然后判断是否合法,不合法的话,继续排序,继续让没有匹配的最小的数加上k,直到合法为止。
#include<stdio.h>
#include<algorithm>
#define N 200
using namespace std;
int a[N];
int main()
{
    int t,n,k,i,j,flag;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        flag=0;
        for(i=1;i<=n;i++)
        {
            sort(a+1,a+1+n);
            for(j=1;j<=n;j++)
            {
                if(a[j]!=j)
                {
                    a[j]+=k;
                    break;
                }
            }
            if(j==n+1)
            {
                flag=1;
                break;
            }
        }
        if(flag==1)
            printf("Jerry\n");
        else
            printf("Tom\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值