读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:每个测试输入包含1个测试用例,格式为
第1行:正整数n 第2行:第1个学生的姓名 学号 成绩 第3行:第2个学生的姓名 学号 成绩 ... ... ... 第n+1行:第n个学生的姓名 学号 成绩其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。
输入样例:3 Joe Math990112 89 Mike CS991301 100 Mary EE990830 95输出样例:
Mike CS991301 Joe Math990112
解题思路:
思路很简单,需要注意的是使用sort()函数时,里面传递的参数类型是指针而不是值,在这点上我调试了好久。
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
class Student
{
public:
string name;
string ID;
int score;
friend ostream& operator<<(ostream &os, const Student &student)
{
os << student.name << " " << student.ID;
return os;
}
};
//sort()函数的比较函数,这里是按score升序排列
bool comparation(Student i, Student j)
{
return i.score < j.score;
}
int main()
{
//输入学生个数
int n;
cin >> n;
//初始化student class
Student * student = new Student[n];
for(int i=0;i<n;i++)
{
string name;
string ID;
int score;
cin >> name;
cin >> ID;
cin >> score;
student[i].name = name;
student[i].ID = ID;
student[i].score = score;
}
sort(student, student+n, comparation);
cout << student[n - 1] << endl;
cout << student[0] << endl;
delete[] student;
return 0;
}