A Knight's Journe
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 40970 | Accepted: 13938 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
If no such path exist, you should output impossible on a single line.
Sample Input
3 1 1 2 3 4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
注意马的跳动列数是按照字典序调的,也就是说必须按照A B C.....A B....这样
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 30;
int vis[maxn][maxn];
int dir[8][2] = {{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
int n,m,flag;
struct Path{
int x,y;
}p[maxn];
void dfs(int x,int y,int step){
if(flag)
return;
p[step].x=x;
p[step].y=y;
if(step==n*m)
{
flag = 1;
return ;
}
Path next;
for(int i = 0;i<8;i++)
{
next.x = x+dir[i][0];
next.y = y+dir[i][1];
if(next.x >=1&&next.x<=m&&next.y>=1&&next.y<=n&&!vis[next.x][next.y])
{
vis[next.x][next.y]=1;
dfs(next.x,next.y,step+1);
vis[next.x][next.y]=0;
}
}
return ;
}
int main()
{
int T;
cin>>T;
for(int t = 1;t<=T;t++){
cin>>n>>m; //输入行数和列数,行数是y的边界,列数是x的边界
memset(vis,0,sizeof(vis));
memset(p,0,sizeof(p));
flag=0;
vis[1][1]=1;
dfs(1,1,1);
printf("Scenario #%d:\n", t);
if(flag){
for(int i = 1;i<=n*m;i++)
printf("%c%d",p[i].x-1+'A',p[i].y);
cout<<endl;
}
else cout<<"impossible"<<endl;
if(t!=T) cout<<endl;
}
return 0;
}
注意模拟的是二维数组的坐标,不要和数学坐标弄淆。