POJ 1274 二分图最大匹配简单单向

The Perfect Stall
Time Limit: 1000MS        Memory Limit: 10000K
Total Submissions: 23153        Accepted: 10312

Description
Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

Sample Output

4

Source

USACO 40


题意:

给n个牛,m个牛棚,这些牛只有到特定的牛棚才能产奶,求最大满足牛需求的头数

简单匈牙利算法,注意是单向图,与我上次发表的双向图模板有少许不同,另外这个题也是多组数据,注意初始化。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int e[500][500];
int match[500];
int book[500];
int n,m;

int dfs(int u)
{
    int i;
    for(i=1;i<=m;i++)
    {
        if(book[i]==0&&e[u][i]==1)
        {
            book[i]=1; //标记点i已访问过
            if(match[i]==0||dfs(match[i])) //核心:比如数据1-4,1-5,2-5,2-6,3-4,1和4匹配,2和5匹配,等3和4匹配时,因为1和4已经匹配,此时match[4]=1,所以需要
            {                              //对dfs(1)继续搜索,寻找1还能和谁匹配,因为此时book[4]已经标记为1,所以搜到5,匹配到1-5,返回到1,退出dfs函数回
                //更新配对关系             //到3的匹配,match[4]=3,3匹配成功。
                match[i]=u;

                return 1;
            }
        }
    }
         return 0;
    }
int main()
{
   //freopen("in.txt","r",stdin);
   int i,j,t1,t2,sum=0;
   int k,a;
   while(scanf("%d%d",&n,&m)!=EOF){
     memset(e,0,sizeof(e));
     memset(book,0,sizeof(book));
     sum=0;
   for(i=1;i<=n;i++){
    scanf("%d",&k);
    for(j=1;j<=k;j++)
    {
        scanf("%d",&a);
    e[i][a]=1;

   }
   }
   for(i=1;i<=n;i++)
    match[i]=0;

   for(i=1;i<=n;i++){
    
    memset(book,0,sizeof(book)); //清空上次搜索时的标记
    if(dfs(i))
        sum++;     //寻找增广路,如果找到,配对数加1.
   }
   printf("%d\n",sum);
   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值