Circle in Square LightOJ - 1022

题目

A circle is placed perfectly into a square. The term perfectly placed means that each side of the square is touched by the circle, but the circle doesn't have any overlapping part with the square. See the picture below.

Now you are given the radius of the circle. You have to find the area of the shaded region (blue part). Assume that pi = 2 * acos (0.0) (acos means cos inverse).

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case contains a floating point number r (0 < r ≤ 1000) denoting the radius of the circle. And you can assume that r contains at most four digits after the decimal point.

Output

For each case, print the case number and the shaded area rounded to two places after the decimal point.

Sample Input

3

20

30.091

87.0921

Sample Output

Case 1: 343.36

Case 2: 777.26

Case 3: 6511.05

Hint

This problem doesn't have special judge. So, be careful about precision problems. Better to add a small value to your result to avoid precision problems. For example, add 10-9 to your result.

思路

水题。。。收获就是10^-9的浮点数要用double, float装不下。。。之前一直不理解题目中的意思。。。。。。

代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <set>
#include <vector>

#define MAX_N 0x3F3F3F3F
const double pi = 2*acos(0.0);
using namespace std;

int main()
{
	int t;
	double r;
	double res;

	cin >> t;
	for (int i = 1; i <= t; i++)
	{
		cin >> r;
		cout << "Case " << i << ": ";

		res = (4 - pi)*r*r;

		cout.setf(ios_base::fixed);
		cout.precision(2);
		cout << res << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值