Discovering Permutations LightOJ - 1023

题目


In this problem you have to find the permutations using the first N English capital letters. Since there can be many permutations, you have to print the first K permutations.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains two integers N, K (1 ≤ N ≤ 26, 1 ≤ K ≤ 30).

Output

For each case, print the case number in a line. Then print the first K permutations that contain the first N English capital letters in alphabetical order. If there are less than K permutations then print all of them.

Sample Input

2

3 8

10 10

Sample Output

Case 1:

ABC

ACB

BAC

BCA

CAB

CBA

Case 2:

ABCDEFGHIJ

ABCDEFGHJI

ABCDEFGIHJ

ABCDEFGIJH

ABCDEFGJHI

ABCDEFGJIH

ABCDEFHGIJ

ABCDEFHGJI

ABCDEFHIGJ

ABCDEFHIJG

思路

next_permutation直接枚举组合

代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <set>
#include <vector>

#define MAX_N 0x3F3F3F3F

using namespace std;

int main()
{
	int T, K, N;
	int k;
	string str;
	cin >> T;
	for (int i = 1; i <= T; i++) {
		cin >> N >> K;
		str.clear();
		for (int n = 0; n < N; n++) {
			str += 'A' + n;
		}
		cout << "Case " << i << ":" << endl;

		k = 0;
        do{
			cout << str << endl;
			if (++k >= K) break;
        } while (next_permutation(str.begin(), str.end()) );

	}


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值