ACM -- Spell checker

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me


思路:

这道题有点小简单,就是简单的进行字符串的比较

首先要判断是否存在,存在的话都直接完事!

后面分三种情况就OK了!

1. 就是长度相等的时候;

2. 就是长度-1的情况;

3. 就是长度+1的情况。



#include <iostream>
#include <vector>
#include <string>
#include <iterator>
#include <algorithm>
using namespace std;

vector<string> vecStrDir;

vector<string> findByLength(int len)
{
	vector<string> vec;
	
	for (vector<string>::iterator it = vecStrDir.begin(); it != vecStrDir.end(); ++it)
	{
		if (it->length() == len)
		{
			vec.insert(vec.end(), *it);
		}
	}

	return vec;
}

bool compareOneDiff(string str1, string str2)
{
	int flag = 0;
	for (int i = 0; i < str1.length(); ++i)
	{
		if (str1[i] != str2[i])
		{
			++flag;
		}
	}
	if (flag <= 1)
	{
		return true;
	}
	return false;
}

bool compareOneLess(string str1, string str2)
{
	int flag = 0;
	for (int i = 0; i < str1.length() + 1; ++i)
	{
		string s0(str2, 0, i);
		string s1(str2, i, 1);
		string s2(str2, i + 1, str2.length() - i -1);
		string s3 = s0 + s2;
		if (!s3.compare(str1))
		{
			return true;
		}
	}
	return false;
}

int main()
{

	//1. 输入字典
	string sWord;
	while (cin >> sWord, sWord.compare("#"))
	{
		vecStrDir.insert(vecStrDir.end(), sWord);
	}

	//2. 输出处理数据
	while (cin >> sWord, sWord.compare("#"))
	{
		vector<string>::iterator it;
		it = find(vecStrDir.begin(), vecStrDir.end(), sWord);
		if (it != vecStrDir.end())
		{
			cout << *it << " is correct";
		}
		else
		{
			cout << sWord << ":";

			//判断长度相等的时候,即修改一个字母的情况
			int ilen = sWord.length();
			vector<string> vecStrHelp;
			vecStrHelp = findByLength(ilen);

			for (vector<string>::iterator it = vecStrHelp.begin(); 
				it != vecStrHelp.end(); ++it)
			{
				string str = *it;
				if (compareOneDiff(sWord, str))
				{
					cout << " " << *it;
				}
			}

			//判断长度+1的情况,即插入一个字母的情况
			vecStrHelp.clear();
			vecStrHelp = findByLength(ilen + 1);
			for (vector<string>::iterator it = vecStrHelp.begin(); 
				it != vecStrHelp.end(); ++it)
			{
				string str = *it;
				if (compareOneLess(sWord, str))
				{
					cout << " " << *it;
				}
			}

			//判断长度-1的情况,即删除一个字母的情况
			vecStrHelp.clear();
			vecStrHelp = findByLength(ilen - 1);
			for (vector<string>::iterator it = vecStrHelp.begin(); 
				it != vecStrHelp.end(); ++it)
			{
				string str = *it;
				if (compareOneLess(str, sWord))
				{
					cout << " " << *it;
				}
			}
		}
		cout << endl;
	}

	return 1;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值