Spell checker

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source




/*题目大意:前面输入一系列字符串
,以“#”结束,后面在输入一系列字符串,同样以“#”结束,问后面的字符串可以由前面哪些字
符串通过添加,删除,替换一个字母得来,按照字典序输出,如果后面的和前面的相同,则直接输出xx
 is correct。
解题方法:先将前面的字符串保存到一颗字典树当中,以此来判断后面的字符串在前
面是否存在,如果不存在再另作判断,看后面的字符串可以由前面哪些字符串通过添加,删
除,替换一个字母得来。*/
#include <iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
typedef struct node
{
    bool isword;
    node *next[26];
    node()//构造函数的初始化;
    {
        isword=false;
        memset(next,0,sizeof(next));
    }
}TreeNode;//字典数的定义;
int cmp(char *s1,char *s2)
{
    return strcmp(s1,s2);
}
void Insert(TreeNode *pRoot,char s1[])//字典树的生成;
{
    int len=strlen(s1);
    for(int i=0;i<len;i++)
    {
        if(pRoot->next[s1[i]-'a']==NULL)
            pRoot->next[s1[i]-'a']=new TreeNode;
        pRoot=pRoot->next[s1[i]-'a'];
    }
    pRoot->isword=true;
}
bool find(TreeNode *pRoot,char s1[])//字典序判断后面的字符串是否在前面出现过
{
    int len=strlen(s1);
    for(int i=0;i<len;i++)
    {
        if(pRoot->next[s1[i]-'a']==NULL)
            return false;
        pRoot=pRoot->next[s1[i]-'a'];
    }
    if(pRoot->isword)
        return true;
    return false;
}
bool inequal(char s1[],char s2[])//判断两字符串是否可能相同或可以转变成同一字符串;
{
    int len1=strlen(s1);
    int len2=strlen(s2);
    int count=0;//计数;
    int i=0,j=0;
    if(len1!=len2)//如果两个字符串长度不相等
    {
        while(i<len1&&j<len2)
        {
            if(s1[i]!=s2[j])
            {
                count++;//遇到不相等的字符,统计数加一
                if(len1>len2)
                    i++;
                else
                    j++;
            }
            else//如果两个字符相等,则下标同时增加一
            {
                i++;
                j++;
            }
        }
        if(count>1)//不相等的字符数大于一,返回false
          return false;
          else
            return true;
    }
    else//当两个字符串相同时,直接判断相同位置不同字符串的数目是否大于一
    {
        while(i<len1)
        {
            if(s1[i]!=s2[i])
                count++;//不相同的字符加一:
            i++;
        }
        if(count==1)//计数等于一,返回true
            return true;
        else
            return false;
    }
}
int main()
{
   int sum=0;
   char s1[10005][55],s2[55];
   TreeNode *pRoot=new TreeNode;
   while(scanf("%s",s1[sum])!=EOF&&s1[sum][0]!='#')
   {
       Insert(pRoot,s1[sum]);//字典树的生成;
       sum++;
   }
   while(scanf("%s",s2)!=EOF&&s2[0]!='#')
   {
       if(find(pRoot,s2))//同一字符串;
        printf("%s is correct\n",s2);
       else
       {
           printf("%s:",s2);
           for(int i=0;i<sum;i++)
           {
               int t=strlen(s1[i])-strlen(s2);
               if(t<=1&&t>=-1)
               {
                   if(inequal(s1[i],s2))//可以由一些字符改变转化成同一字符;
                      printf(" %s",s1[i]);
               }
           }
           printf("\n");
       }
   }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值