UVa 227 Puzzle

UVa 227 Puzzle

这个题怕不是有毒,先是我第二个样例的空格死活不识别,后来我改成了<’A’||>’Z’才能标记的,好歹本地对了,提交上去WA了,然后我从网上搜AC代码,怎么看都觉得我没有问题,把AC代码粘到我本机上跑结果却是不对的,23333。
A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 small
squares of equal size. A unique letter of the alphabet was printed on each small square. Since there
were only 24 squares within the frame, the frame also contained an empty position which was the same
size as a small square. A square could be moved into that empty position if it were immediately to the
right, to the left, above, or below the empty position. The object of the puzzle was to slide squares
into the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original configuration and in its configuration after
the following sequence of 6 moves:
1) The square above the empty position moves.
2) The square to the right of the empty position moves.
3) The square to the right of the empty position moves.
4) The square below the empty position moves.
5) The square below the empty position moves.
6) The square to the left of the empty position moves.
Write a program to display resulting frames given their initial configurations and sequences of moves.
Input
Input for your program consists of several puzzles. Each is described by its initial configuration and
the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting
configuration. Subsequent lines give the sequence of moves.
The first line of the frame display corresponds to the top line of squares in the puzzle. The other
lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains
exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost
square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square
moves into the empty position. A denotes that the square above the empty position moves; B denotes
that the square below the empty position moves; L denotes that the square to the left of the empty
position moves; R denotes that the square to the right of the empty position moves. It is possible that
there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move
occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread
over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.
Output
Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If
the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final
configuration should be displayed.
Format each line for a final configuration so that there is a single blank character between two
adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior
position, then it will appear as a sequence of 3 blanks — one to separate it from the square to the left,
one for the empty position itself, and one to separate it from the square to the right.
Separate output from different puzzle records by one blank line.
Note: The first record of the sample input corresponds to the puzzle illustrated above.
Sample Input
TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAAAABBRRRLL0
Z
Sample Output
Puzzle #1:
T R G S J
X O K L I
M D V B N
W P A E
U Q H C F
Puzzle #2:
A B C D
F G H I E
K L M N J
P Q R S O
T U V W X
Puzzle #3:
This puzzle has no final configuration.

别人的AC代码
https://blog.csdn.net/mobius_strip/article/details/43916257

我的错误代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#include<string.h>
#define maxn 1010
#define ll long long
#define INF 0x3f3f3f3f3f3f3f3f
using namespace std;
char a[6][6];
char s[maxn];
int main()
{
//  freopen("input.txt","r",stdin);
//  freopen("output.txt","w",stdout);
    int i,j,x,y,flag,ans;
    char c;
    ans=0;
    while(gets(a[0])){
        if(a[0][0]=='Z')
        break;
        for(i=1;i<5;i++){
            gets(a[i]);
        }
        ans++;
        flag=0;
        for(i=0;i<5;i++){
            for(j=0;j<5;j++){
//              cout<<i<<" "<<j<<" "<<a[i][j]<<endl;
                if(a[i][j]<'A'||a[i][j]>'Z'){
                    x=i;
                    y=j;
                }
            }
        }
//      cout<<x<<" "<<y<<endl;
        while(scanf("%c",&c)&&c!='0'){
            if(flag)
            continue;
            if(c=='A'){
                if(x-1<0){
                    flag=1;
                }
                else{
                    a[x][y]=a[x-1][y];
                    a[x-1][y]=' ';
                    x--;
//                  cout<<c<<" "<<x<<" "<<y<<endl;
                }
            }
            if(c=='B'){
                if(x+1>=5){
                    flag=1;
                }
                else{
                    a[x][y]=a[x+1][y];
                    a[x+1][y]=' ';
                    x++;
//                  cout<<c<<" "<<x<<" "<<y<<endl;
                }
            }
            if(c=='L'){
                if(y-1<0){
                    flag=1;
                }
                else{
                    a[x][y]=a[x][y-1];
                    a[x][y-1]=' ';
                    y--;
//                  cout<<c<<" "<<x<<" "<<y<<endl;
                }
            }
            if(c=='R'){
                if(y+1>=5){
                    flag;
                }
                else{
                    a[x][y]=a[x][y+1];
                    a[x][y+1]=' ';
                    y++;
//                  cout<<c<<" "<<x<<" "<<y<<endl;
                }
            }
        }
        getchar();
        printf("Puzzle #%d:\n",ans);
        if(flag){
            printf("This puzzle has no final configuration.\n");
        }
        else{
            for(i=0;i<5;i++){
                for(j=0;j<4;j++){
                    printf("%c ",a[i][j]);
                }
                printf("%c",a[i][j]);
                printf("\n");
            }
        }
//      memset(a,' ',sizeof(a));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值