数值三角形的一个递归解法(超时)

The Triangle
Time Limit: 1000ms, Special Time Limit:2000ms, Memory Limit:32768KB
Total submit users: 162, Accepted users: 153
Problem 10014 : No special judgement
Problem description
7

3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.


Input
Your program is to read from standard input. The first line contains one integer T, the number of test cases, for each test case: the first line contain a integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output
Your program is to write to standard output. The highest sum is written as an integer for each test case one line.

Sample Input
1

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
Sample Output
30
Problem Source
IOI 1994

自下而上相加:

#include  < iostream >
using   namespace  std;
#define  MAX 110
#define  X -1

int  visitnode( int  num[][MAX], int  i , int  j);
main()
{
 
int  i = 0 ,j = 0 ;
 
int  n = 0 ,k = 0 ,total = 0 ;
 
int  num[MAX][MAX];
 scanf(
" %d " , & total);  // number of cases
 
 
for (k = 0 ;k < total;k ++ ){
     scanf(
" %d " , & n);
     
for (i = 0 ;i < n;i ++ )
         
for (j = 0 ;j <= i;j ++ )scanf( " %d " , & num[i][j]);     // input sum  
      for (i = 0 ;i <= n;i ++ )num[n][i] = X;               
     
/* for(i=0;i<=n;i++){
         for(j=0;j<=i;j++)printf("%d ",num[i][j]); 
         printf(" ");
     } 
*/    
     
for (i = n - 1 ;i > 0 ;i -- ){
          
for (j = 0 ;j < n;j ++ ){
             num[i
- 1 ][j] += max(num[i][j],num[i][j + 1 ]);               
          }                    
     }
     
/*
     for(i=0;i<=n;i++){
         for(j=0;j<=i;j++)printf("%d ",num[i][j]); 
         printf(" ");
     }   
     
*/
     printf(
" %d " ,num[ 0 ][ 0 ]);                       
 }
       
 
return   0 ;
}

 

递归解法(超时):

#include  < stdio.h >
#define  MAX 110
#define  X -1

int  visitnode( int  num[][MAX], int  i , int  j);
main()
{
 
int  i = 0 ,j = 0 ;
 
int  n = 0 ,k = 0 ,total = 0 ;
 
int  num[MAX][MAX];
 scanf(
" %d " , & total);  // number of cases
 
 
for (k = 0 ;k < total;k ++ ){
     scanf(
" %d " , & n);
     
for (i = 0 ;i < n;i ++ )
         
for (j = 0 ;j <= i;j ++ )scanf( " %d " , & num[i][j]);     // input sum  
      for (i = 0 ;i <= n;i ++ )num[n][i] = X;               
     
/* for(i=0;i<=n;i++){
         for(j=0;j<=i;j++)printf("%d ",num[i][j]); 
         printf(" ");
     }    
*/
     printf(
" %d " ,visitnode(num, 0 , 0 ));                       
 }
       
 system(
" PAUSE " );
}

int  visitnode( int  num[][MAX], int  i , int  j)
{
    
int  a = 0 ,b = 0 ;
    
if (num[i][j] == X) return   0 ;
    a
= num[i][j] + visitnode(num,i + 1 ,j);
    b
= num[i][j] + visitnode(num,i + 1 ,j + 1 );
    
return  a > b ? a:b;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值