杭电-FatMouse' Trade

FatMouse' Trade

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 59   Accepted Submission(s) : 17
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500


AC代码如下

#include <iostream>
#include <iomanip>
using namespace std;
class Trade
{
public:
    int javab;
    int food;
    double bili()
    {
        return 1.0*javab/food;
    }
};
int main()
{
    int m,n;
    Trade trade[1000];
    while(cin>>m>>n&&m!=-1&&n!=-1)
    {
        for(int i=0; i<n; ++i)
            cin>>trade[i].javab>>trade[i].food;
        int i,k,j;
        Trade t;
        for(i=0; i<n-1; i++)
        {
            k=i;
            for(j=i+1; j<n; j++)
            {
                if(trade[k].bili()<trade[j].bili())
                    k=j;
            }
            t=trade[k];
            trade[k]=trade[i];
            trade[i]=t;
        }
        double sum=0;
        for(int i=0; i<n&&m!=0; ++i)
        {
            if(m>=trade[i].food)
            {
                m-=trade[i].food;
                sum+=trade[i].javab;
            }
            else
            {
                sum+=m*(trade[i].bili());
                m=0;
            }
        }
        cout<<fixed<<setprecision(3)<<sum<<endl;
    }
    return 0;
}
心得:

吐血了。。。这英文我也是醉了,一边翻译一边错

用GUN C++是报错的,用VS C++才AC,尼玛。。。。。。。。。。

心得:


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值