poj2828 Buy Tickets(树状数组 + 二分)


Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 18825 Accepted: 9344

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Valiin the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

题意:

给定一个n 表示有n个元素,有n行操作指定插入的位置和插入的元素,要求输出最终的序列。

思路:

很明显前面插入的元素会被后面插入的位置所影响,由于最后插入的元素的位置一定就是该位置,所以我们倒着思考,先放最后的元素依次往前扫。对于任意的两个整数对(pos1,val1)和(pos2, val2)保证(pos1,val1)在(pos2,val2)之前出现,如果pos1小于pos2,后面的整数对是不影响前面整数对的位置关系的,否则val1的位置必然要受到val2的影响而向后移动一位。所以pos1和pos2之前就存在一个逆序关系, 想到用树状数组或者线段树, 线段树比较容易维护, 这里想要写树状数组来练练。至于待插入的位置刚好是他前面空位数,空位数用树状数组维护。所以要插入的位置 就是空位数 后面的那个空位。

经验:

通过这个题,自己对二分理解又有了更深的理解。

AC代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>

using namespace std;
const int maxn = 2e5 + 10;
int ans[maxn + 10];
struct node
{
    int pos;
    int val;
} Tickets[maxn + 10];

int c[maxn + 10];
int n;
inline int lowbit(int x)
{
    return x & (-x);
}
void Add(int i, int x)
{
    while(i <= n)
    {
        c[i] += x;
        i += lowbit(i);
    }
}
int Sum(int x)
{
    int sum = 0;
    while(x > 0)
    {
        sum += c[x];
        x -= lowbit(x);
    }
    return sum;
}
int main()
{
    while(scanf("%d", &n) != EOF)
    {
        memset(c, 0, sizeof(c));
        for(int i = 1; i <= n; i ++)
        {
            scanf("%d%d", &Tickets[i].pos, &Tickets[i].val);
            Tickets[i].pos ++;
        }

        for(int i = n; i >= 1; i --)
        {
            int l = 1, r = n;
            int cur = 1;
            while(l <= r)
            {
                int mid = (l + r) >> 1;
                if(mid - Sum(mid) >= Tickets[i].pos)
                {
                    r = mid - 1;
                    cur = mid;
                }
                else l = mid + 1;
            }
            ans[cur] = Tickets[i].val;
            Add(cur, 1);
        }
        for(int i = 1; i <= n; i ++)
            printf("%d%c", ans[i], i == n ? '\n' : ' ');
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值