POJ2828 Buy Tickets 树状数组

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

 
提交地址 :  Buy Tickets 
 
题目大意 : 来了n个人, 每个人在队列里选择了一个位置插入, 问最后的序列是什么样的;
 
分析:
时光倒流:因为最后的人肯定是站在自己想占的地方, 所以从后往前便于处理;
首先设一个人都没有, 序列全部为1(后面讲为什么);
然后插入最后一个人, 那样例二来说, 他肯定是插在了自己想在的地方, 所以把他所站的地方设为0, 序序列便成为了 0 1 1 1;
然后考虑倒数第二个人, 他要去第二的位置但是在他之前已经插入了最后一个人, 所以他最终的位置一定不是在第二个位置;
那是在第几个位置呢? 答案是:第二个1!为什么, 因为1表示此位置还未被占, 所以他要站在第二个没有被占得位置上;
求前缀1的值我们可以用树状数组维护(这就是初始值是1的原因!);
但是对于没个人都要枚举一遍显然是不现实的, 又因为前缀和满足单调性, 所以直接暴力二分OK;
 
应该特别好理解;
不理解的看看代码就差不多了;
代码奉上:
 
//By zZhBr
#include <iostream>
#include <cstdio> 
#include <algorithm>
using namespace std;

int n;


struct pro
{
    int pos;
    int num;
}pr[200010];

int ans[200010];

int tr[200010];

int lowbit(int x)
{
    return x & -x;
}

void add(int x, int y)
{
    while(x <= n)
    {
        tr[x] += y;
        x += lowbit(x);
    }
}

int sum(int x)
{
    int ans = 0;
    while(x != 0)
    {
        ans += tr[x];
        x -= lowbit(x);
    }
    return ans;
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        for(register int i = 1 ; i <= n ; i ++) ans[i] = 0;
        for(register int i = 1 ; i <= n ; i ++)
        {
            scanf("%d%d", &pr[i].pos, &pr[i].num);
            add(i, 1);
        }
        
        for(register int i = n ; i >= 1 ; i --)
        {
            int p = pr[i].pos + 1;
            
            if(sum(p) == p)
            {
                ans[p] = pr[i].num;
                add(p, -1);
                continue;
            }
            
            int l = p, r = n;
            while(l  < r)
            {
                int mid = l + r >> 1;
                if(sum(mid) >= p) r = mid;
                else l = mid + 1;
            }
            
            ans[l] = pr[i].num;
            add(l, -1);
            
        }
        
        for(register int i = 1 ; i <= n ; i ++)
        {
            printf("%d ", ans[i]);
        }
        printf("\n");
        
    }
    return 0;
}
zZhBr

 

 
 

转载于:https://www.cnblogs.com/BriMon/p/8969424.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值