1006. Sign In and Sign Out

Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题意

给出员工的打卡记录表,包含员工编号、签入时间、签出时间,找出第一个签入开门和最后一个签出锁门的员工,并打印其编号。

思路

题目较简单,利用sort函数,对签入时间进行升序排序、对签出时间进行降序排序即可。

更简单的方法是,直接在读入过程中进行字符串比较。


代码实现——sort函数

#include <cstdio>
#include <algorithm>
using namespace std;

struct record
{
	char id[16];        // 记录员工编号
	int in[3];          // 记录签入时间
	int out[3];	        // 记录签出时间
} rec[1000];

bool cmp_in(record a, record b)     //签入升序比较函数
{
	if (a.in[0] != b.in[0])
		return a.in[0] < b.in[0];
	else if (a.in[1] != b.in[1])
		return a.in[1] < b.in[1];
	else
		return a.in[2] < b.in[2];
}

bool cmp_out(record a, record b)    //签出降序比较函数
{
	if (a.out[0] != b.out[0])
		return a.out[0] > b.out[0];
	else if (a.out[1] != b.out[1])
		return a.out[1] > b.out[1];
	else
		return a.out[2] > b.out[2];
}

int main()
{
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%s", rec[i].id);
		for (int j = 0; j < 3; j++)
		{
			scanf("%d", &rec[i].in[j]);
			getchar();
		}
		for (int j = 0; j < 3; j++)
		{
			scanf("%d", &rec[i].out[j]);
			getchar();
		}
	}
	sort(rec, rec + n, cmp_in);         // 签入升序排序
	printf("%s ", rec[0].id);
	sort(rec, rec + n, cmp_out);        // 签出降序排序
	printf("%s", rec[0].id);
}

代码实现——字符串比较

#include <cstdio>
#include <cstring>

int main()
{
	char unlock[16], lock[16];                              // 记录答案
	char first[9] = {"24:00:00"}, last[9] = {"00:00:00"};   // 时间比较对象
	char in[9], out[9], id[16];
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%s %s %s", id, in, out);
		if (strcmp(in, first) < 0)                          // 更新最小签入时间
		{
			strcpy(unlock, id);
			strcpy(first, in);
		}
		if (strcmp(out, last) > 0)                          // 更新最大签出时间
		{
			strcpy(lock, id);
			strcpy(last, out);
		}
	}
	printf("%s %s", unlock, lock);
	return 0;
	
}

参考

CSDN博客 - sup_heaven

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值