1063. Set Similarity

Set Similarity

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题意

给出一系列数字序列,计算指定两组序列的相似度,相似度计算公式为:
N c N t ∗ 100 % \frac{N_c}{N_t} * 100\% NtNc100%
其中 N C N_C NC为交集不同数字个数, N t N_t Nt为并集不同数字个数。

思路

先用set对每组序列进行去重和递增排序,再依次枚举序列a中元素,看能否在序列b中找到,以此计算出交集和并集中元素个数。


代码实现

#include <cstdio>
#include <set>
using namespace std;

const int maxn = 51;
set<int> sets[maxn];

int main()
{
	int n, m, x, k, a, b;
	int Nc, Nt;
	set<int>::iterator it;
	
	scanf("%d", &n);
	for (int i = 1; i <= n; i++)        // 序列去重排序后存储
	{
		scanf("%d", &m);
		for (int j = 0; j < m; j++)
		{
			scanf("%d", &x);
			sets[i].insert(x);
		}
	}
	
	scanf("%d", &k);
	for (int i = 0; i < k; i++)
	{
		Nc = 0;
		scanf("%d %d", &a, &b);
		for (it = sets[a].begin(); it != sets[a].end(); it++)   // 枚举a中元素,在b中查找
			if (sets[b].find(*it) != sets[b].end())
				Nc++;
		Nt = sets[a].size() + sets[b].size() - Nc;
		printf("%.1f%%\n", 1.0 * Nc / Nt * 100);
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值