Set Similarity

该问题要求计算两个整数集合的相似度,定义为两者共享的唯一元素数量(Nc)除以两集合中所有唯一元素总数(Nt)的100%。给定测试用例包含集合的数量、每个集合的元素以及查询对。对于每个查询,输出集合对的相似度,精确到1位小数。
摘要由CSDN通过智能技术生成

问题 A: Set Similarity (25)
时间限制: 1 Sec 内存限制: 32 MB
提交: 292 解决: 126
[提交][状态][讨论版][命题人:外部导入]
题目描述
Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.
输入
Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
输出
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
样例输入
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
样例输出
50.0%
33.3%
自己代码:

#include<iostream>
#include<set>
using namespace std;
int main() {
	int N,num,element;
	int search[2];
	double shuchu[2000];
	set<int> input[50];
	while (scanf("%d", &N) != EOF) {//共有N组set输入
		int jishu = 0;
	    for (int i = 0; i < N; i++)
		{
			scanf("%d", &num);//每组set有几个数
			for (int j = 0; j < num; j++) {
				scanf("%d", &element);
				input[i].insert(element);
			}
		}
		//输入要查询的set组数
		scanf("%d", &num);
		for (int i = 0; i < num; i++) {
			scanf("%d %d", &search[0], &search[1]);
			//查找相同的个数
			int Nc = input[search[0] - 1].size() + input[search[1] - 1].size();
			set<int> merge;//取出要查询的两个set的合并
			for (set<int>::iterator it = input[search[0] - 1].begin(); it != input[search[0] - 1].end();
				it++) {
				merge.insert(*it);
			}
			for (set<int>::iterator it = input[search[1] - 1].begin(); it != input[search[1] - 1].end();
				it++) {
				merge.insert(*it);
			}
			int Nt = merge.size();
			Nc = Nc - Nt;
			double result = (double)Nc / (double)Nt * 100;
			shuchu[jishu++] = result;
		}
		for (int i = 0; i < jishu; i++)
			printf("%.1f%%\n", shuchu[i]);
	}
	
	system("pause");
	return 0;
}

注意:本题练习的是set容器的用法,set的主要用途是自动去重并按升序排序,若需要处理不唯一的情况,则需要使用multiset,另外还增加了unordered_set,以散列代替内部红黑树。要读懂题意。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值