1007. Maximum Subsequence Sum

Maximum Subsequence Sum

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题意

给定包含n个数字的序列,输出和最大的连续子序列的和、子列首元素、子列末元素。若序列中全为负数,则令最大和为0,并输出整个序列的首元素和末元素。

思路

直接暴力算的话很简单,二重循环枚举所有子序列,只要注意特殊情况的输出即可,时间复杂度为 O ( n 2 ) O(n^2) O(n2)。下面介绍一种复杂度为 O ( n ) O(n) O(n)的思路:对于非负整数序列,最大和子列必然是以非负数开始的,所以首先先找到第一个非负整数,并记录其位置;向后遍历,不断累加元素并判断,若和大于max则更新max、子列起始位置、子列结束位置,若和变为负数,则无论下一个元素是什么,加上当前和只会使总的和变小,所以从下一个元素开始,重复上述步骤,直到遍历完所有数字。


代码实现

#include <cstdio>

int arr[10010];

int findMax(int arr[], int n, int &first, int &last)
{
	int i = 0;
	int max = 0;
	int sum = 0;
	int f;      // f用来临时存储子列开始位置
	
	while (arr[i] < 0)      // 找到第一个非负的元素
		i++;
	f = i;
	first = last = i;	

	while (i < n)
	{
		sum += arr[i];
		if (sum < 0)        // 当sum小于0时,寻找新的子列
		{
			while (arr[i] < 0 && i < n)
				i++;
			sum = 0;        // 注意对于新子列要初始化sum
			if (i < n)
				f = i;      // 记录新子列起始位置
		}
		else if (sum > max) // 和大于max时,更新各项数据
		{
			max = sum;
			first = f;
			last = i;
			i++;
		}
        else
            i++;
	}

	return max;
}

int main()
{
	bool flag = true;       // flag用于判断是否是全负序列
	int n;
	int first, last;
	int max;
	
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &arr[i]);
		if (arr[i] >= 0)
			flag = false;
	}
	
	if (flag)
		printf("0 %d %d", arr[0], arr[n - 1]);
	else
	{
		max = findMax(arr, n, first, last);
		printf("%d %d %d", max, arr[first], arr[last]);
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值