1007. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, ..., NK }.  A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K.  TheMaximum Subsequence is the continuous subsequence which has the largest sum of its elements.  For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines.  The first line contains a positive integer K (<= 10000).  The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line.  In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case).  If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:

10 1 4

这道题是简单的动态规划题,题目不难  但是要看清楚题目 

output the first and the last numbers of the whole sequence 意思是找出最大最小的数值,不是数组下标值 题目给出的例子也很有欺骗性  我就是没看清题目 一直通不过!

 

参考代码:

#include <iostream>

using namespace std;

int main()
{
    int n,first,last;
    int tempFirst,tempLast,maxSum,tempSum;
    cin>>n;
    int *arr = new int[n];
    for(int i=0;i<n;i++){
        cin>>arr[i];
    }//完成数据的输入

    first = last = -1;
    tempFirst = tempLast = 0;
    maxSum = tempSum = 0;
    for(int i=0;i<n;i++){
        if(arr[i]>0){
            tempSum += arr[i];
            tempLast = i;
            if(tempSum>maxSum){
                maxSum = tempSum;
                first = tempFirst;
                last = tempLast;
            }
        }else{
            tempSum += arr[i];
            if(tempSum<0){
                tempSum = 0;
                tempFirst = i+1;
                tempLast = tempFirst;
            }else{
                if(tempSum==0 && first==-1){
                    first = tempFirst;
                    last = tempLast;
                }else{
                    tempLast++;
                }
            }
        }
    }

    if(first==-1){
        cout<<0<<" "<<arr[0]<<" "<<arr[n-1];
    }else{
        cout<<maxSum<<" "<<arr[first]<<" "<<arr[last];
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值