1032. Sharing

Sharing

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.

image

You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题意

给出两个链表的首地址及结点总数,并给出每个结点的地址、数据、下个结点地址,寻找两个链表第一个共用结点的地址,如果不存在则输出-1。

思路

地址的长度固定且数据范围不大,应当用静态链表处理。题目实际上与结点内数据没有关系,只需要考虑结点本身,因此可以采取下列措施:在定义结构体时多用一个bool成员来判断该结点是否被访问过,首先遍历第一个链表,将每个结点标记为已访问,再遍历第二个链表,如果当前结点已被访问,则返回该结点地址;如果所有结点都没被访问过,则返回-1。


代码实现

#include <cstdio>

struct Node
{
    char ch;
    int next;
    bool flag;      // 判断是否被访问过
} node[100000];

int findPos(int a, int b)
{
    while (a != -1)     // 遍历第一个链表并标记已访问
    {
        node[a].flag = true;
        a = node[a].next;
    }

    while (b != -1)     // 查找第二个链表中是否有已访问结点
    {
        if (node[b].flag)
            return b;
        b = node[b].next;
    }

    return -1;
}

int main()
{
    int a, b;
    int n;
    int x, y;
    char c;
    int pos;

    scanf("%d %d %d", &a, &b, &n);
    for (int i = 0; i < n; i++)
    {
        scanf("%d %c %d", &x, &c, &y);
        node[x].ch = c;
        node[x].next = y;
    }

    pos = findPos(a, b);
    if (pos != -1)
        printf("%05d", pos);         // 注意格式输出
    else
        printf("%d", pos);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值