1034. Head of a Gang

Head of a Gang

One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threshold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

题意

给定通话组数n和通话长度阈值k,并列出每一组的通话者的名字和通话长度。只要两人互相通过话,就属于同一组,每组的值定义为组内所有通话的长度之和,只要组的值大于阈值k,且组内成员人数大于2,就将这组视为一个目标团伙,团伙的头目定义为组内通话长度最大的人。要求按字典序输出所有团伙头目的名字以及团伙成员人数。

思路

将每个人的通话长度视作点权,两个人之间的通话长度视作边权,则题目实质上是构建图,要求找到所有连通块,并根据连通块的结点数和边权和判断该块是否满足要求,如果满足则输出连通块中点权最大的结点及总结点个数。用DFS进行处理。


代码实现

#include <iostream>
#include <map>
#include <string>
using namespace std;

const int maxn = 2001;  // 边上限1000,则结点数上限2000
int n, k;       
int g[maxn][maxn] = {0}, weight[maxn] = {0};        // 邻接矩阵,结点点权记录
int total = 0;      // 结点数统计
map<string, int> ID;        // 将名字映射为编号
map<int, string> NAME;      // 将编号映射为名字
map<string, int> Gang;      // 记录所有团伙信息(头目名字,人数),并自动排序
bool visit[maxn] = {false}; // 判断结点是否已访问过

int changeToID(string s)
{
    if (ID.find(s) == ID.end())     // 该名字还没有分配编号
    {
        ID[s] = total;      // 分配编号为当前人数
        NAME[total] = s;    // 编号映射为名字
        return total++;     // 返回编号并使人数+1
    }
    else
        return ID[s];       // 已分配过编号
}

void DFS(int id, int &numP, int &sumW, int &head)   // 参数分别为当前访问编号,组内结点数,边权和,点权最大结点
{
    visit[id] = true;
    numP++;
    if (weight[id] > weight[head])
        head = id;

    for (int i = 0; i < total; i++)     // 枚举所有人
        if (g[id][i] > 0)   // 两点间有边
        {
           sumW += g[id][i];    
           g[id][i] = g[i][id] = 0;     // 加完边权后删除该边,防止多次重复访问
           if (!visit[i])       // i未被访问
                DFS(i, numP, sumW, head);
        }
}

void DFSTraversal()
{
    for (int i = 0; i < total; i++)
        if (!visit[i])      // i未被访问
        {
            int numP = 0, sumW = 0, head = i;
            DFS(i, numP, sumW, head);
            if (sumW > k && numP > 2)   // 判断该组是否符合边权大于k,结点数大于2
                Gang[NAME[head]] = numP;    // 符合,存储头目名字和人数
        }
}

int main()
{
    string name1, name2;
    int w;

    cin >> n >> k;
    for (int i = 0; i < n; i++)
    {
        cin >> name1 >> name2 >> w;
        int id1 = changeToID(name1);
        int id2 = changeToID(name2);
        g[id1][id2] += w;       // 边权增加
        g[id2][id1] += w;
        weight[id1] += w;       // 点权增加
        weight[id2] += w;
    }

    DFSTraversal();

    map<string, int>::iterator it;
    cout << Gang.size() << endl;
    for (it = Gang.begin(); it != Gang.end(); it++)
        cout << it->first << " " << it->second << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值