1076. Forwards on Weibo

Forwards on Weibo

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题意

微博用户发布一条信息时,粉丝可以转发该信息(最多转发一次,且发布不算转发),给定n个用户的关注列表,以及转发次数上限L,要求输出指定用户发布后在转发上限内信息被转发的次数。

思路

根据用户关注可以构建图(邻接表),再以特定结点为起点,进行BFS,只要层数不大于L就累加转发次数。

要注意的是,题目给出的是用户的关注列表而不是粉丝列表,构建邻接表时要反过来;同时用户的编号从1开始而不是从0开始。


代码实现

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;

const int maxn = 1001;
int n, l;
bool inq[maxn];     // 是否入过队

struct node
{
    int id;
    int level;      // 记录结点层数
};

vector<int> ulist[maxn];    // 邻接表

int BFS(int x)
{
    int ans = 0;
    queue<node> q;      // 为了方便记录层数,用node类型的队列
    node user;
    user.id = x;
    user.level = 0;     // 起始结点层数为0
    q.push(user);
    inq[x] = true;      // 已入队标记
    while (!q.empty())
    {
        node now = q.front();   // 队首结点出队
        q.pop();
        for (int i = 0; i < ulist[now.id].size(); i++)  // 考察每个相连的结点
        {
            int temp = ulist[now.id][i];
            if (!inq[temp])     // 尚未入队
            {
                user.id = temp;
                user.level = now.level + 1;     // 当前结点的层数为上层结点 层数+1
                if (user.level <= l)    // 未达到转发层数上限再继续,剪枝
                {
                    ans++;
                    q.push(user);
                    inq[temp] = true;
                }
            }
        }
    }
    return ans;
}

int main()
{
    int num, f;
    int k;

    scanf("%d%d", &n, &l);
    for (int i = 1; i <= n; i++)
    {
        scanf("%d", &num);
        for (int j = 1; j <= num; j++)
        {
            scanf("%d", &f);
            ulist[f].push_back(i);      // 注意顺序
        }
    }

    scanf("%d", &k);
    for (int i = 1; i <= k; i++)
    {
        memset(inq, false, sizeof(inq));    // 对于每一个新发布的消息都要重置inq
        scanf("%d", &f);
        printf("%d\n", BFS(f));
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值