1140. Look-and-say Sequence

Look-and-say Sequence

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

题意

给定一个初始数字d和目标序列编号n,要求输出第n个序列。

序列的生成规则是,后一个序列是对前一个序列中连续数字个数的描述。以 d = 1 为例:

  • 序列①:1,即为d本身;
  • 序列②:11,表明①中有1个1;
  • 序列③:12,表明②中有2个1;
  • 序列④:1121,表明③中有1个1、1个2;
  • 序列⑤:122111,表明④中有2个1、1个2、1个1;
  • ……

思路

直接按照题意进行模拟即可,详见代码。


代码实现

#include <iostream>
#include <string>
#include <vector>
using namespace std;

void nextString(string &s)      // 生成下一个序列
{
    vector<char> temp;          // 存储当前序列各个数字及其个数

    int x = s[0] - '0';         // 当前数字
    int cnt = 0;                // 当前数字个数
    for (int i = 0; i < s.length(); i++)
    {
        if (s[i] - '0' == x)
            cnt++;
        else            // 旧数字连续序列结束
        {
            temp.push_back(x);
            temp.push_back(cnt);
            x = s[i] - '0';     // 更新当前数字
            cnt = 1;
        }
    }
    temp.push_back(x);      // 将当前序列最后一个数字及其个数存入temp
    temp.push_back(cnt);

    s.clear();      // 清空当前序列
    for (int i = 0; i < temp.size(); i++)
        s += temp[i] + '0';
}

int main()
{
    string d;
    int n;

    cin >> d >> n;

    for (int i = 0; i < n - 1; i++)     // 只要执行 n - 1 次
        nextString(d);

    cout << d;

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值