E - A Magic Lamp HDU 3183(在删除指定个数的数后的到最小的数,且去前导0)

在不少于应剩余的数字个数时,按着顺序,依次寻找最小数。放到新的数组里。注意去除前导零。

Description

Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?

Input

There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.

Output

For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 

Sample Input

178543 4 
1000001 1
100001 2
12345 2
54321 2

Sample Output

13
1
0
123
321
#include<stdio.h>
#include<string.h>
using namespace std;
char a[1020],b[1020];
int n;
int main()
{
    int t;
    while(scanf("%s%d",a,&n)!=EOF)
    {
        int k=0;
        t=strlen(a);
        int z=0;
        int j=t-n;
        while(j--)
        {int w=z;
        for(int i=z+1;i<t-j;i++)
        {
            if(a[w]>a[i])
                 w=i;
        }
        b[k++]=a[w];
        z=w+1;
        b[k]='\0';
        }
        int i=0;
        while(b[i]=='0'&&i<t-n)
        {
            i++;
        }
        if(i==t-n)
            printf("0");
        else
        {for(int j=i;j<t-n;j++)
            printf("%c",b[j]);
        }
            printf("\n");
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值