大数 a[i]=a[i-1]+a[i-2]*2

当时比赛并未做出来,主要被大数的处理难住了,水平太菜。//大数  a[i]=a[i-2]*2+a[i-1] 

A. Tiling

Time Limit: 1000ms
Memory Limit: 32768KB
64-bit integer IO format:  %I64d      Java class name:  Main

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?

Here is a sample tiling of a 2x17 rectangle.


Input

Input is a sequence of lines, each line containing an integer number  0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2x n rectangle.

Sample Input

2
8
12

Sample Output

3
171
2731
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int a[270][270];
int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF)
    {
        a[0][0]=1;
        a[1][0]= 1;
        a[2][0]= 3;
        int temp=0;
        for(i=3; i<=250; i++)
        {
            for(int j=0; j<=100; j++)
            {
                temp+=a[i-1][j]+a[i-2][j]*2;
                a[i][j]=temp%10;
                temp/=10;//数组存大数

            }
        }
        for(i=99;i>=0;i--)
		{
			if(a[n][i]!=0)
				break;
		}
		for(;i>=0;i--)
		{
			printf("%d",a[n][i]);
		}
		printf("\n");

    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值