Tiling (递推)

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.

Input
Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.
Output
For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.
Sample Input
2
8
12
100
200
Sample Output
3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

做法:可转化为
F(n)=F(n-1)+2*F(n-2)
为什么F(n-2)的系数为2呢,因为当我们考虑F(n-1)的时候,即在n位置放置了一个2*1的瓦片,而到n-2时,已经在n-1考虑过了两个2*1的瓦片竖着放的情况,所以不用再考虑一遍了。

大数,直接用java吧,
注意当n=0的时候f(0)=1

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    static BigInteger[] arr=new BigInteger[260];
    static  BigInteger solve(int a)
    {
        if(arr[a]!=null)return arr[a];
        if(a==0)return new BigInteger("1");
        if(a==2)return new BigInteger("3");
        if(a==1)return new BigInteger("1");

        return arr[a]=solve(a-1).add(solve(a-2).multiply(new BigInteger("2"))); 

    }

    public static void main(String[] args) {
        Scanner scan=new Scanner(System.in);
        while(scan.hasNext())
        {
            int a=scan.nextInt();
            System.out.println(solve(a));
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值