poj1426(深搜)

154 篇文章 0 订阅
82 篇文章 0 订阅

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111


题目大意是让你找出一个只含0和1的数使之为输入的数的倍数。这种代码好懂自己写却不好写的深搜题还得多做多做啊!!5555555555

(题目说最多100位,实质上这题用无符号长整是可以做到的)


#include <iostream>
#include<memory.h>
#include<stdio.h>
using namespace std;
typedef unsigned __int64 ll;
ll t;bool flag;
void dfs(ll t,int n,int w)
{
    if(flag==1)return;
    if(t%n==0)
    {
        cout<<t<<endl;
        flag=1;
        return ;
    }
    if(w==19)return ;
    dfs(t*10,n,w+1);
    dfs(t*10+1,n,w+1);
}

int main()
{
   int n;
   while(cin>>n&&n!=0)
   {
       flag=0;
       dfs(1,n,0);
   }
    return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值