hdu1198(并查集的应用)

154 篇文章 0 订阅
82 篇文章 0 订阅

Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows. 


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC 
FJK 
IHE 

then the water pipes are distributed like 


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show. 
 

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50. 
 

Output

For each test case, output in one line the least number of wellsprings needed. 
 

Sample Input

    
    
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

Sample Output

    
    
2 3


很明显的并查集题目,将水管能连通的就连成一片就ok,关键这题把输入之后的处理变麻烦了一点,确实很麻烦,我当时判断的时候都感觉本来想一种种情况判断的,后来直接把矩阵外围加了一圈表示路径不通,这样稍微还简化了一点代码。

int type[12][4]={{1,1,0,0},{0,1,1,0},{1,0,0,1},{0,0,1,1},
                {0,1,0,1},{1,0,1,0},{1,1,1,0},{1,1,0,1},
                {1,0,1,1},{0,1,1,1},{1,1,1,1},{0,0,0,0}},f[N];

我就用这12个方向数组来表示连通与否,1表示可以连通,0就不行。

然后,接下来做的,就是赶紧敲代码把~!


#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int N=60*60+1;
int type[12][4]={{1,1,0,0},{0,1,1,0},{1,0,0,1},{0,0,1,1},
                {0,1,0,1},{1,0,1,0},{1,1,1,0},{1,1,0,1},
                {1,0,1,1},{0,1,1,1},{1,1,1,1},{0,0,0,0}},f[N];
int ff(int x)
{
    int tem=f[x];
    if(tem!=x)
    f[x]=ff(tem);
    return f[x];
}

void join(int a,int b)
{
    int tem1=ff(a),tem2=ff(b);
    f[tem1]=f[tem2];
}

int count(int n)
{
        int t[N];
        for(int i=1;i<=n;i++)
            t[i]=ff(i);
        sort(t+1,t+n+1);
        return unique(t+1,t+n+1)-(t+1);
}
char oo[60][60];
int main()
{
    int n,m;
    while(scanf("%d%d",&m,&n)!=EOF&&!(m==-1&&n==-1))
    {
        for(int i=0;i<=N;i++)
            f[i]=i;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
            scanf(" %c",&oo[i][j]);
        for(int i=0;i<=n+1;i++)
            oo[0][i]=oo[m+1][i]='A'+11;
        for(int i=0;i<=m+1;i++)
            oo[i][0]=oo[i][n+1]='A'+11;

           /* for(int i=1;i<=m;i++)
            {for(int j=1;j<=n;j++)
            cout<<oo[i][j]<<' ';
            cout<<endl;
            }*/

        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
            {
                if(type[oo[i][j]-'A'][3]==1&&type[oo[i+1][j]-'A'][1]==1)
                        {if(ff((i-1)*n+j)!=ff((i)*n+j))
                        join((i-1)*n+j,(i)*n+j);//cout<<"yes下"<<i<<' '<<j<<endl;
                        }
                if(type[oo[i][j]-'A'][2]==1&&type[oo[i][j+1]-'A'][0]==1)
                        {if(ff((i-1)*n+j)!=ff((i-1)*n+j+1))
                        join((i-1)*n+j,(i-1)*n+j+1);//cout<<"yes右"<<i<<' '<<j<<endl;
                        }
                if(type[oo[i][j]-'A'][1]==1&&type[oo[i-1][j]-'A'][3]==1)
                        {if(ff((i-1)*n+j)!=ff((i-2)*n+j))
                        join((i-1)*n+j,(i-2)*n+j);//cout<<"yes上"<<i<<' '<<j<<endl;
                        }
                if(type[oo[i][j]-'A'][0]==1&&type[oo[i][j-1]-'A'][2]==1)
                        {if(ff((i-1)*n+j)!=ff((i-1)*n+j-1))
                        join((i-1)*n+j,(i-1)*n+j-1);//cout<<"yes左"<<i<<' '<<j<<endl;
                        }
            }
        int s=count(n*m);
        printf("%d\n",s);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值