hdu3833(暴力)

202 篇文章 0 订阅
31 篇文章 0 订阅

YY's new problem

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5384    Accepted Submission(s): 1508


Problem Description
Given a permutation P of 1 to N, YY wants to know whether there exists such three elements P[i 1], P[i 2], P[i 3] that 
P[i 1]-P[i 2]=P[i 2]-P[i 3], 1<=i 1<i 2<i 3<=N.
 

Input
The first line is T(T<=60), representing the total test cases.
Each test case comes two lines, the former one is N, 3<=N<=10000, the latter is a permutation of 1 to N.
 

Output
For each test case, just output 'Y' if such i 1, i 2, i 3 can be found, else 'N'.
 

Sample Input
  
  
2 3 1 3 2 4 3 2 4 1
 

Sample Output
  
  
N Y

暴力要有方法。。。。。


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
/*const int M=200000;
int ip;
int head[M],cd[M],rd[M];
struct data
{
    int v,next;
}tu[M];
void init(int n)
{
    memset(head,-1,sizeof(head));
    memset(rd,0,sizeof(rd));
    memset(cd,0,sizeof(cd));
    ip=0;
}
void add(int u,int v)
{
    tu[ip].v=v,tu[ip].next=head[u],head[u]=ip++;
}
*/
int zb[10010],a[10010];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(int i=0; i<n; i++)
            {scanf("%d",&a[i]);zb[a[i]]=i;}
        int flag=0;
        for(int i=0; i<n; i++)
        {
            for(int j=i+1; j<n; j++)
            {
                if((a[i]+a[j])%2==0)
                {
                    if(zb[(a[i]+a[j])/2]>i&&zb[(a[i]+a[j])/2]<j)
                    {
                        flag=1;
                        break;
                    }
                }
            }
            if(flag)break;
        }
        if(flag)printf("Y\n");
        else printf("N\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值