uva1423(拓扑排序)

202 篇文章 0 订阅
123 篇文章 0 订阅

Given a sequence of integers, a1a2,..., an , we define its sign matrix S such that, for 1$ \le$i$ \le$j$ \le$n , Sij = `` + "if Sij = `` - " if ai +...+ aj < 0 ; and Sij = ``0" otherwise.

For example, if (a1a2a3a4) = (- 1, 5, - 4, 2) , then its sign matrix S is a 4×4 matrix:


 1234
1-+0+
2 +++
3  --
4   +


We say that the sequence (-1, 5, -4, 2) generates the sign matrix. A sign matrix is valid if it can be generated by a sequence of integers.

Given a sequence of integers, it is easy to compute its sign matrix. This problem is about the opposite direction: Given a valid sign matrix, find a sequence of integers that generates the sign matrix. Note that two or more different sequences of integers can generate the same sign matrix. For example, the sequence (-2, 5, -3, 1) generates the same sign matrix as the sequence (-1,5, -4,2).

Write a program that, given a valid sign matrix, can find a sequence of integers that generates the sign matrix. You may assume that every integer in a sequence is between -10 and 10, both inclusive.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case consists of two lines. The first line contains an integer n (1$ \le$n$ \le$10) , where n is the length of a sequence of integers. The second line contains a string of n(n + 1)/2characters such that the first n characters correspond to the first row of the sign matrix, the next n - 1 characters to the second row, ... , and the last character to the n -th row.

Output

Your program is to write to standard output. For each test case, output exactly one line containing a sequence of n integers which generates the sign matrix. If more than one sequence generates the sign matrix, you may output any one of them. Every integer in the sequence must be between -10 and 10, both inclusive.

Sample Input

3 
4 
-+0++++--+ 
2 
+++ 
5 
++0+-+-+--+-+--

Sample Output

-2 5 -3 1 
3 4 
1 2 -3 4 -5


这道题很容易转化成:
已知s[0],s[1]...s[n]的大小关系,求a[1],a[2]...a[n]的值
不要想直接转化得到数列a的大小关系,那样不好找。而已知s后,可以直接用s[n]-s[n-1]求a[n];
并且只要让相邻的s相差为1,a的值的绝对值就不会超过10.
然后拓扑排序时先找到所有入度为0的点后,再进行“减度”。

不过要注意我们的s[0]一样也作为图中的一个点来参与计算,不能当做0 。。。


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
int rd[11],tu[11][11],s[11],aa[11];
void topu(int n)
{
    int oo=-10,flag=1;
    while(flag)
    {
        flag=0;
        queue<int>q;
        for(int i=0; i<=n; i++)
            if(rd[i]==0)
            {
                rd[i]--;
                flag=1;
                q.push(i);
                s[i]=oo;
            }
        oo++;
        while(!q.empty())
        {
            int t=q.front();
            q.pop();
            for(int i=0; i<=n; i++)
                if(tu[t][i])
                    rd[i]--;
        }
    }
    //for(int i=0;i<=n;i++)
    //  printf("%d ",s[i]);puts("");
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(rd,0,sizeof(rd));
        memset(tu,0,sizeof(tu));
        int n;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            for(int j=i; j<=n; j++)
            {
                char a;
                scanf(" %c",&a);
                if(a=='+')
                    tu[i-1][j]=1,rd[j]++;
                else if(a=='-')
                    tu[j][i-1]=1,rd[i-1]++;
            }
        topu(n);
        for(int i=1; i<n; i++)
        {
            aa[i]=s[i]-s[i-1];
            printf("%d ",aa[i]);
        }
        printf("%d\n",s[n]-s[n-1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值