hdu4324(拓扑排序)

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4238    Accepted Submission(s): 1669


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No

标准的拓扑排序。。。。可恶的是这题卡输入,真的是无语死,用scanf("%s",)就能过,scanf("%c")就超时。。。。。真涨姿势


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
int o=1;
const int maxn=2010;
int head[maxn],ip,rd[maxn];
struct data
{
    int v,next;
} tu[maxn*maxn];
void init(int n)
{
    ip=0;
    memset(rd,0,sizeof(rd));
    memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
    tu[ip].v=v,tu[ip].next=head[u],head[u]=ip++;
}

void topu(int n)
{
    int s=0;
    queue<int>q;
    for(int i=0; i<n; i++)
        if(!rd[i])
            q.push(i);
    while(!q.empty())
    {
        int tem=q.front();
        q.pop();
        s++;
        for(int i=head[tem]; i!=-1; i=tu[i].next)
        {
            int hh=tu[i].v;
            rd[hh]--;
            if(!rd[hh])
                q.push(hh);
        }
    }
    if(s==n)
        printf("Case #%d: No\n",o++);
    else printf("Case #%d: Yes\n",o++);
}
char x[2010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        init(n);
        for(int i=0; i<n; i++)
        {
            scanf("%s",x);
            for(int j=0; j<n; j++)
            {
                if(x[j]=='1')
                    add(i,j),rd[j]++;
            }
        }
        topu(n);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值