hdu 4324 Triangle LOVE(拓扑排序)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4324

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3858    Accepted Submission(s): 1516


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Author
BJTU
 

Source

题目大意:给一个n*n的矩阵,Map[i][j]表示i喜欢j;在这个矩阵表示的范围内,找到是否存在三角恋的关系。
解题思路:做的第一道拓扑排序判环题目。判断其中是否有环就可以了,如果存在环必然存在三元环(这个是根据这道题目得出的结论)。
先介绍一下拓扑排序:对一个有向无环图(Directed Acyclic Graph简称DAG)G进行拓扑排序,是将G中所有顶点排成一个线性序列,使得图中任意一对顶点u和v,若边(u,v)∈E(G),则u在线性序列中出现在v之前。 简单的说,由某个集合上的一个 偏序 得到该集合上的一个 全序 ,这个操作称之为拓扑排序。
再通俗一点就是,一个点一个点的去删除,删掉的必须是入度为0的,如果将入度为0的全部删完,还有剩余边的话就会产生死锁,其中必存在环。

详见代码。
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int indir[2010];//用来表示入度
char Map[2010][2010];//存储的是i,j两个节点的关系,1:i love j,0:j love i

int main()
{
    int t;
    scanf("%d",&t);
    int ff=1;
    while (t--)
    {
        memset(indir,0,sizeof(indir));
        int flag=0;
        int n;
        scanf("%d",&n);
        for (int i=0; i<n; i++)
        {
            scanf("%s",Map[i]);
            for (int j=0; j<n; j++)
            {
                if (Map[i][j]=='1')//i love j,也就是i指向j
                    indir[j]++;//j的入度++
            }
        }
        int j;
        for (int i=0; i<n; i++)
        {
            for (j=0; j<n; j++)
                if (indir[j]==0)
                    break;
            if (j==n)//如果全部找完都没有发现入度为0的必存在环。
            {
                flag=1;
                break;
            }
            else
            {
                indir[j]--;//j的入度删掉
                for (int k=0;k<n;k++)//j指向的点删掉
                {
                    if (Map[j][k]=='1')
                    {
                        indir[k]--;
                    }
                }
            }
        }
        if (flag==1)
            printf ("Case #%d: Yes\n",ff++);
        else
            printf ("Case #%d: No\n",ff++);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值