ACboy needs your help
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6054 Accepted Submission(s): 3309
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
Sample Output
3 4 6
题意:ACboy要花m天来复习n门课,现在告诉你他花j天在第i门课上会得到的奖励,让你给他算出最优解。
思路:01背包稍微变形一下,其实是一模一样的。
dp[i]表示花i天来复习的最优解,然后转移方程是dp[j]=max(dp[j],dp[j-k]+val[i][k]);
其实想出状态转移方程不难,我们要做的就是一一对应01背包的各种条件,显然这题m天是背包容量,花k天来复习是消耗的容量,val[i][j]则是对应的得到的价值。
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
int val[110][110],dp[110];
int main()
{
int m,n;
while(~scanf("%d%d",&n,&m)&&m+n)
{
for(int i=1; i<=n; i++)
for(int j=1; j<=m; j++)
scanf("%d",&val[i][j]);
memset(dp,0,sizeof(dp));
for(int i=1; i<=n; i++)
for(int j=m; j>=0; j--)
for(int k=1; k<=j; k++)
dp[j]=max(dp[j],dp[j-k]+val[i][k]);
printf("%d\n",dp[m]);
}
return 0;
}