Divide the Sequence
Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 2232 Accepted Submission(s): 628
Problem Description
Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.
Input
The input consists of multiple test cases.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2⋯An .
1≤n≤1e6
−10000≤A[i]≤10000
You can assume that there is at least one solution.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2⋯An .
1≤n≤1e6
−10000≤A[i]≤10000
You can assume that there is at least one solution.
Output
For each test case, output an integer indicates the maximum number of sequence division.
Sample Input
6 1 2 3 4 5 6 4 1 2 -3 0 5 0 0 0 0 0
Sample Output
6 2 5
题意很容易理解不多说。
思路:反向dp,类似求最长子段和的方法一遍dp就ok。
#include <iostream>
#include<string.h>
#include<vector>
#include<queue>
#include<algorithm>
#include<stdio.h>
#include<math.h>
#include<map>
#include<stdlib.h>
#include<time.h>
using namespace std;
typedef long long ll;
ll a[1000010],dp[1000010];
int main()
{
int n;
while(~scanf("%d",&n))
{
ll ans=0;
for(int i=1; i<=n; i++)
scanf("%I64d",&a[i]);
dp[n+1]=0;
for(int i=n; i>=1; i--)
if(dp[i+1]+a[i]>=0)
ans++,dp[i]=0;
else
dp[i]=dp[i+1]+a[i];
printf("%I64d\n",ans);
}
return 0;
}