HDU_5783_DivideTheSequence(贪心)

13 篇文章 0 订阅

Divide the Sequence

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 637    Accepted Submission(s): 330


Problem Description
Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.
 

Input
The input consists of multiple test cases.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2An .
1n1e6
10000A[i]10000
You can assume that there is at least one solution.
 

Output
For each test case, output an integer indicates the maximum number of sequence division.
 

Sample Input
  
  
6 1 2 3 4 5 6 4 1 2 -3 0 5 0 0 0 0 0
 

Sample Output
  
  
6 2 5
 

Author
ZSTU
 

Source
 

Recommend
wange2014

题意

题意每一个前缀和为非负的串可以划分成一个区间

问最多可以划分多少个区间


做法

反着扫

扫到非负了就加起来独自成为一个区间即可

保证了至少有一解,就少了很多特殊情况。


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

typedef long long LL;
const int M=1e6+5;
int nu[M];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&nu[i]);
        int ans=0;
        LL sum=0;
        for(int i=n;i>=1;i--)
        {
            sum+=nu[i];
            if(sum>=0)
            {
                ans++;
                sum=0;
            }
            else
                continue;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值